POj 1860 Currency Exchange(SPFA判负权)

Currency Exchange
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 31841 Accepted: 12118

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES


题目大意是给你n种货币,m个兑换,每个兑换对应a->b的汇率,手续费,和b->a的汇率,手续费,问倒腾来倒腾去最后倒腾回来能不能把钱变多,明显只要有个环能使钱一直增多就好了嘛!

SPFA判正权回路,有的话可以增多,否则不可以。

代码(队列版的SPFA):

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<cstring>
#include<string>
#include<vector>
#include<cmath>
#include<map>
using namespace std;
typedef long long ll;
#define mem(a,b) memset(a,b,sizeof(a))
const int maxn = 1e5+5;
const int ff = 0x3f3f3f3f;
struct edge
{
	int to;
	double r;//汇率
	double c;//手续费
	int next;
} edge[maxn];

int n,m,s;
double v;
int len;
int head[maxn];
double dis[maxn];
int vis[maxn];
int num[maxn];

void add(int u,int v,double r,double c)
{
	edge[len].to = v;
	edge[len].r = r;
	edge[len].c = c;
	edge[len].next = head[u];
	head[u] = len++;
}

bool spfa()
{
	queue<int > q;
	dis[s] = v;
	q.push(s);
	vis[s] = 1;
	num[s]++;
	while(!q.empty())
	{
		int t = q.front();
		q.pop();
		vis[t] = 0;
		for(int i = head[t];i!= -1;i = edge[i].next)
		{
			int id = edge[i].to;
			if(dis[id]< (dis[t]-edge[i].c)*edge[i].r)
			{
				dis[id] = (dis[t]-edge[i].c)*edge[i].r;
				if(vis[id] == 0)
				{
					q.push(id);
					vis[id] = 1;
					num[id]++;
					if(num[id]> n)//有正权回路返回1即可 
						return 1;
				}
			}
		}
	}
	return 0;
}

void init()
{
	for(int i = 1;i<= n;i++)
		dis[i] = -1;
	mem(vis,0);
	mem(num,0);
	mem(head,-1);
}

int main()
{
	cin>>n>>m>>s>>v;
	init();
	for(int i = 1;i<= m;i++)
	{
		int a,b;
		double ra,rb,ca,cb;
		scanf("%d %d %lf %lf %lf %lf",&a,&b,&ra,&ca,&rb,&cb);
		add(a,b,ra,ca);
		add(b,a,rb,cb);
	}
	if(spfa())
		cout<<"YES"<<endl;
	else
		cout<<"NO"<<endl;
	
	return 0;
}
GO!


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值