POJ 2348 Euclid's Game(博弈)

Euclid's Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9824 Accepted: 4023

Description

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7): 
         25 7

         11 7

          4 7

          4 3

          1 3

          1 0

an Stan wins.

Input

The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output

For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input

34 12
15 24
0 0

Sample Output

Stan wins
Ollie wins

题意:每个人每次可以用大数减去小数的若干倍,结果必须是非负整数,轮流操作,先出现0的获胜.

思路:若过程中n%m = 0,则获胜.否则  假设2*m>n>m,则若(n,m)为必胜点,则(n,n-m)为必败点. 假设(r+1)*m>n>m,则若(n,n-r*m)为必败点,则(n,n-(r-1)*m)为必胜点,所以只要有一方出现n>= 2*m的情况他就是胜者,否者就看操作次数的奇偶性.

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<cstring>
#include<string>
#include<vector>
#include<cmath> 
#include<map>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
typedef long long ll;
const int maxn = 2e6+5;
const int ff = 0x3f3f3f3f;
map<string,int> mp;
map<string,int>::iterator it;

int n,m;

int main()
{
	while(cin>>n>>m,m+n)
	{
		int cnt = 0;
		while(m> 0)
		{
			if(n< m)
				swap(n,m);
			if(n/m>= 2||n%m == 0)
				break;
			n-=m;
			cnt++;
		}
		if(cnt%2)
			cout<<"Ollie wins"<<endl;
		else
			cout<<"Stan wins"<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值