POJ1325Machine Schedule(二分图最小点覆盖)

Machine Schedule
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 16318 Accepted: 6961

Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem. 

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, ..., mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, ... , mode_m-1. At the beginning they are both work at mode_0. 

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y. 

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y. 

The input will be terminated by a line containing a single zero. 

Output

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output

3


题意:两台机器分别有n,m种工作模式,k件物品分别可以工作在两台机器的两种工作模式下,问最少需要切换多少次工作模式.

思路:每个物品相当于一条边,两台机器的工作模式是图的两部分点,求最小点覆盖所有边即可.

最小点覆盖 == 二分图最大匹配

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<cstring>
#include<string>
#include<vector>
#include<cmath>
#include<map>
#include<set>
#define mem(a,b) memset(a,b,sizeof(a))
#define mod 1000000007
using namespace std;
typedef long long ll;
const int maxn = 1e6+500;
const double esp = 1e-7;
const int ff = 0x3f3f3f3f;
map<int,int>::iterator it;

int n,m,k;
int mp[520][520];
int g[520],d[520],vis[520];

int find(int x)
{
	for(int i = 1;i<= m;i++)
	{
		if(mp[x][i]&&!vis[i])
		{
			vis[i] = 1;
			if(!g[i]||find(g[i]))
			{
				g[i] = x;
				return 1;
			}
		}
	}
	
	return 0;
}

void init()
{
	mem(g,0);
	mem(d,0);
	mem(mp,0);
}

int main()
{
	while(scanf("%d",&n)&&n)
	{
		scanf("%d %d",&m,&k);
		init();
		
		for(int i = 1;i<= k;i++)
		{
			int a,b,c;
			scanf("%d %d %d",&a,&b,&c);
			mp[b][c] = 1;
			d[b]++;
		}
		
		int num = 0;
		for(int i = 1;i<= n;i++)	
		{
			if(!d[i])
				continue;
			
			mem(vis,0);
			if(find(i))
				num++;
		}
		
		printf("%d\n",num);
	}
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值