HDU-6319 Ascending Rating(思维)

                                          Ascending Rating

Problem Description
Before the start of contest, there are n ICPC contestants waiting in a long queue. They are labeled by 1 to n from left to right. It can be easily found that the i-th contestant's QodeForces rating is ai.
Little Q, the coach of Quailty Normal University, is bored to just watch them waiting in the queue. He starts to compare the rating of the contestants. He will pick a continous interval with length m, say [l,l+m−1], and then inspect each contestant from left to right. Initially, he will write down two numbers maxrating=−1 and count=0. Everytime he meets a contestant k with strictly higher rating than maxrating, he will change maxrating to ak and count to count+1.
Little T is also a coach waiting for the contest. He knows Little Q is not good at counting, so he is wondering what are the correct final value of maxrating and count. Please write a program to figure out the answer.
 

Input
The first line of the input contains an integer T(1≤T≤2000), denoting the number of test cases.
In each test case, there are 7 integers n,m,k,p,q,r,MOD(1≤m,k≤n≤107,5≤p,q,r,MOD≤109) in the first line, denoting the number of contestants, the length of interval, and the parameters k,p,q,r,MOD.
In the next line, there are k integers a1,a2,...,ak(0≤ai≤109), denoting the rating of the first k contestants.
To reduce the large input, we will use the following generator. The numbers p,q,r and MOD are given initially. The values ai(k<i≤n) are then produced as follows :
ai=(p×ai−1+q×i+r)modMOD

It is guaranteed that ∑n≤7×107 and ∑k≤2×106.
 

Output
Since the output file may be very large, let's denote maxratingi and counti as the result of interval [i,i+m−1].
For each test case, you need to print a single line containing two integers A and B, where :
AB==∑i=1n−m+1(maxratingi⊕i)∑i=1n−m+1(counti⊕i)

Note that ``⊕'' denotes binary XOR operation.
 

Sample Input
1
10 6 10 5 5 5 5
3 2 2 1 5 7 6 8 2 9
 

Sample Output
46 11
 

题意:给出n个数,让你查询每一个长度为m的区间内,从第一个元素开始最大值变换了几次,最大值是谁,把他们与i异或求和.

思路:这个题正着不好做,确实很难维护~我们可以倒着看,维护一个严格上升队列,队列内的元素位置差不能超过m,倒着维护.每次新加入的元素都往里把比他小的挤出去,并且把在m长度区间外的也弹出去.这样最大值和最大值变换次数都很容易求了.

代码:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn = 1e7+5;

int n,m,k;
int p,q,r;
ll mod;
ll a[maxn],b[maxn];
bool vis[maxn];

int main()
{
	int t;
	scanf("%d",&t);
	
	while(t--)
	{
		scanf("%d %d %d %d %d %d %lld",&n,&m,&k,&p,&q,&r,&mod);		
		
		for(int i = 1;i<= k;i++)
			scanf("%d",&a[i]);
		for(ll i = k+1;i<= n;i++)
		{
			a[i] = p*a[i-1]+q*i+r;
			if(a[i]> mod) a[i]%= mod;
		}
		for(int i = 1;i<= n;i++) vis[i] = 0;
		
		int top = 0,down = 1,tmp = a[n-m+1];
		for(int i = n-m+2;i<= n;i++)
		{
			if(a[i]> tmp)
			{
				tmp = a[i];
				vis[i] = 1;
			}
		}
		
		for(int i = n;i> n-m+1;i--)//先把最后的一部分上升序列压进去
			if(vis[i]) b[++top] = i;
		
		ll ans1 = 0,ans2 = 0;
		for(int i = n-m+1;i>= 1;i--)
		{
			while(down<= top&&a[b[top]]<= a[i]) top--;//挤掉小的元素
			while(down<= top&&b[down]> i+m-1) down++;//弹出超出区间范围的元素
			b[++top] = i;
			ans1+= a[b[down]]^i;
			ans2+= (top-down+1)^i;
		}
		
		printf("%lld %lld\n",ans1,ans2);
	}	
	
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值