hdu3549(网络流入门题-最大流的sap算法)

                      链接:   Flow Problem (hdu3549)

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 13628    Accepted Submission(s): 6504


Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 

Sample Input
  
  
2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
 

Sample Output
  
  
Case 1: 1 Case 2: 2
 


本题数据范围比较小,因此我直接用二维数组存储边,用边的话好像效率会差一些!



#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<cmath>
#include<cstring>
using namespace std;
const int inf=100000000;
int map[155][155],n,m,vd[155],dis[155];

void _init()
{
    memset(map,0,sizeof(map));
    memset(dis,0,sizeof(dis));
    memset(vd,0,sizeof(vd));
}

int dfs(int v,int flow)
{
    int temp,delta=0,i;
    if(v==n) return flow;
    for(i=1;i<=n;i++)
     if(map[v][i]&&dis[v]==dis[i]+1)
    {
        temp=dfs(i,min(map[v][i],flow-delta));
        if(temp>0)
        {delta+=temp;
        map[v][i]-=temp;
        map[i][v]+=temp;
        if(delta==flow) return flow;}
    }
    vd[dis[v]]--;    
    if(vd[dis[v]]==0) dis[1]=n;
    dis[v]++;
    vd[dis[v]]++;
    return delta;
}
int main()
{
    int T,kkk=0;
    cin>>T;
while(T--)
{
    int Flow,ans=0;
    _init();
    
    int x,y,z;
    scanf("%d%d",&n,&m);  
    for(int i=1;i<=m;i++)
    {
        scanf("%d%d%d",&x,&y,&z);
        map[x][y]+=z;
    }    
    while(dis[1]<n){
          Flow=dfs(1,inf);
        ans+=Flow;    
    }
     printf("Case %d: %d\n",++kkk,ans);
}
    return 0;
}    


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值