Problem C: OverFlow
Time Limit: 1 Sec Memory Limit: 128 MBSubmit: 52 Solved: 16
[ Submit][ Status][ Web Board]
Description
Write a program that reads an expression consisting of two non-negative integer and an operator. Determine if either integer or the result of the expression is too large to be represented as a ``normal'' signed integer (type integer if you are working Pascal, type int if you are working in C).
Input
An unspecified number of lines. Each line will contain an integer, one of the two operators + or *, and another integer.
interger bit less than 12.
Output
For each line of input, print the input followed by 0-3 lines containing as many of these three messages as are appropriate: ``first number too big'', ``second number too big'', ``result too big''
Sample Input
9999999999999999999999 + 11
Sample Output
9999999999999999999999 + 11
first number too big
result too big
HINT
解题思路:
1、找到最大值#define Max 2147483647.0
2、大于它的就输出too big
3、因为只有+ * 所以有一个too big 则 result too big
4、借用double
#include <cstdio>
#include <cstdlib>
#define Max 2147483647.0
#define Max_A 1000
char c_a[Max_A],c_b[Max_A];
char fuhao;
int main()
{
while (~scanf("%s %c %s",c_a, &fuhao, c_b))
{
double first = atof(c_a), scond = atof(c_b), result;
printf("%s %c %s\n",c_a, fuhao, c_b);
if (first > Max)
printf("first number too big\n");
if (scond > Max)
printf("second number too big\n");
if (fuhao == '+')
result = first + scond;
else if (fuhao == '*')
result = first * scond;
if (result > Max)
printf("result too big\n");
}
return 0;
}