1112 Stucked Keyboard(map+set)

给定一个因按键卡住而重复显示的字符串,你需要找出可能卡住的按键及原始字符串。输入包含重复次数k和屏幕上显示的结果,输出卡住的按键和修复后的文本。示例中,k=3,字符串为'caseee1__thiiis_iiisss_a_teeeeeest',卡住的按键为'e'和'i',原始文本为'case1__this_isss_a_teest'。
摘要由CSDN通过智能技术生成

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

Input Specification:
Each input file contains one test case. For each case, the 1st line gives a positive integer k (1<k≤100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

Output Specification:
For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:

3
caseee1__thiiis_iiisss_a_teeeeeest

Sample Output:

ei
case1__this_isss_a_teest

#include<iostream>
#include<map>
#include<set>
using namespace std;
map<char,bool>mp;
set<char>done;
/*有一种特殊情况暂时不考虑,测试点也没有涉及到*/
int main(){
	int k;
	scanf("%d",&k);
	string s;
	cin>>s;
	int len=s.size();
	int cnt=1;
	char pre='#';//#并没有什么特殊含义,放到下面这个循环里面看看就懂了 
	for(int i=0;i<len;i++){//用这样一个方式来把字符串中出现的字符判为true或false 
		if(s[i]==pre) cnt++;
		else{
			cnt=1;
		}
		mp[s[i]]=(cnt%k==0);
		pre=s[i];
	}
	for(int i=0;i<len;i++){//这个循环用来把坏键装进set容器,set本身又有自动排序和去重的功能(但其实根本没用到去重的功能... 
		if(mp[s[i]]&&done.find(s[i])==done.end()){
			printf("%c",s[i]);
			done.insert(s[i]);
		}
	}
	printf("\n");
	for(int i=0;i<len;i++){
		if(mp[s[i]]==true) i=i+k-1;
		printf("%c",s[i]);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值