hdu2795_Billboard_线段树

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 21247    Accepted Submission(s): 8773


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1

题意:

给你一个高为h,宽为w的公告板,张贴n张通知,每张通知表(为1*wi的规格)尽可能的往左上角贴,如果没有位置张贴次长通知表输出-1,否则输出在第几行张贴此表。


这道题一开始想暴力解决(毕竟2000ms的限制),但被lower_bound卡住,后来用二分做没做出来。

最终还是用了线段树。

但用线段树还是要注意空间开的大小的问题。


代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>

using namespace std;
const int maxn=3000005;
int a[maxn];int ans;
int h,m,n;
struct Node{
    int l,r;
    int val;
}node[maxn<<2];
void build(int l,int r,int v)//构建线段树;
{
    node[v].l=l;
    node[v].r=r;
    if(node[v].l==node[v].r){node[v].val=m;return ;}//左右相等时则点就确定了,直接给该树叶赋值w;
    int mid=(l+r)/2;
    build(l,mid,v<<1);
    build(mid+1,r,v<<1|1);
    node[v].val=max(node[v<<1].val,node[v<<1|1].val);//将左右树叶的最大值赋值给父节点;
}

void query(int v,int k)
{
    if(node[v].l==node[v].r)
    {
        node[v].val-=k;
        ans=node[v].l;
        return ;
    }
    if(node[v<<1].val>=k)//如果上边行列(即左子树)有空余的位置,则向左边查询;
    query(v<<1,k);
    else if(node[v<<1|1].val>=k)
    query(v<<1|1,k);
    node[v].val=max(node[v<<1].val,node[v<<1|1].val);//节点的更新
}

int main()
{
    /*freopen("billboard.in","r",stdin);
        freopen("billboard.out","w",stdout);*/

    while(~scanf("%d%d%d",&h,&m,&n))
    {

        h=min(h,n);//如果n小于h的话会出现问题(自己思考);
        build(1,h,1);
        int tmp;
        ans=0;
        while(n--)
        {
            scanf("%d",&tmp);
            if(node[1].val<tmp)//如果根节点都已经没有空间了那么整个板子都贴不下这张通知表,返回-1即可;
            {
                printf("-1\n");
                continue;
            }
            else
            query(1,tmp);
            printf("%d\n",ans);

        }
    }
    return 0;
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值