hdu4602_Partition_思维+递推+快速幂

Partition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3331    Accepted Submission(s): 1283


Problem Description
Define f(n) as the number of ways to perform n in format of the sum of some positive integers. For instance, when n=4, we have
  4=1+1+1+1
  4=1+1+2
  4=1+2+1
  4=2+1+1
  4=1+3
  4=2+2
  4=3+1
  4=4
totally 8 ways. Actually, we will have f(n)=2 (n-1) after observations.
Given a pair of integers n and k, your task is to figure out how many times that the integer k occurs in such 2 (n-1) ways. In the example above, number 1 occurs for 12 times, while number 4 only occurs once.
 

Input
The first line contains a single integer T(1≤T≤10000), indicating the number of test cases.
Each test case contains two integers n and k(1≤n,k≤10 9).
 

Output
Output the required answer modulo 10 9+7 for each test case, one per line.
 

Sample Input
  
  
2 4 2 5 5
 

Sample Output
  
  
5 1

题意:让你输出在以n为和的各种组合里k的个数

思路:

通过枚举找规律,你会发现4 2其实是和3 1等价的,4 3是和2 1等价,也就是说任何一个数里找k都能化简成另一数里找1,抱着这样的思路开始找递推公式。

最后的出的递推公式是a(n)=2*a(n-1)+2^(n-3);

(因为第n个数里的1的个数等于上一个数尾部加上1和尾部数加上1,那么第n个数的前一半为第n-1的行数+a(n-1)为a(n-1)+2^(n-2),后一半因为尾部的数都加上1了,那么其解尾就不会有1,则为a(n-1)-2^(n-3),化简后即为上式。)

那么有了上式之后即可推出:2^(n-2)*a(2)+(n-2)*2^(n-3);a(2)=2 就有2^(n-2)*2+(n-2)*2^(n-3);

之后快速幂解决就行了。

(坑点:用2^(n-3)*a(3)+(n-3)*2^(n-3)就过不了,试了n次 ,感觉有点坑。。。不,是特别坑!)

代码:

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <algorithm>
#define MOD 1000000007
typedef long long LL;
using namespace std;
LL qpow(LL m,LL n,LL k)
{
    LL b=1;
    while(n>0)
    {
        if(n&1)b=(b*m)%k;
        n=n>>1;
        m=(m*m)%k;
    }return b;
}
int main()
{
     LL n,k;
     int t;
     LL ph=phi(MOD);
     scanf("%d",&t);

     while(t--)
     {      LL ans;
         scanf("%lld%lld",&n,&k);
         if(n<k)ans=0;
         if(n==k)ans=1;
         else
         {
             LL a3=5;
             LL m=n-k+1;
            if(m==2)
             ans=2;
             else
             {
                 ans=((2*qpow(2,m-2,MOD)%MOD)+(m-2)*qpow(2,m-3,MOD)%MOD)%MOD;
             }

         }printf("%lld\n",ans);
     }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值