hdu 1024 (经典dp,多段子序列最大和)

Max Sum Plus Plus

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem. 

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n(1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n). 

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed). 

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^ 

Input

Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n
Process to the end of file. 

Output

Output the maximal summation described above in one line. 

Sample Input

1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output

6
8

Hint

Huge input, scanf and dynamic programming is recommended.

 

题意:给定一个数组,要求你在这个数组中找出 m 组不交叉连续的子序列,使得这m 组子序列的和最大。

下面是我抄袭的思路:

设Num为给定数组,n为数组中的元素总数,Status[i][j]表示前 j 个数在选取第 j 个数的前提下分成 i 段的最大值,可知:最后一个段包含a[j]。(这很关键),状态转移方程为:

Status[i][j]=Max(Status[i][j-1]+Num[i],Max(Status[i-1][0]~Status[i-1][j-1])+Num[i])

乍看一下这个方程挺吓人的,因为题中n的限定范围为1~1,000,000而m得限定范围没有给出,m只要稍微大一点就会爆内存。但仔细分析后就会发现Status[i][j]的求解只和Status[*][j]与Status[*][j-1]有关所以本题只需要两个一维数组即可搞定状态转移。

在进行更进一步的分析还会发现其实Max(Status[i-1][0]~Status[i-1][j-1])根本不需要单独求取。在求取now_Status(保存本次状态的数组)的过程中即可对pre_Status(保存前一次状态的数组)进行同步更新。

其中, Status[i][j-1]+Num[i] 表示Num[i]  表示放在第 i 组里面,  Max(Status[i-1][0]~Status[i-1][j-1])+Num[i]  这个数自成一组

 

AC代码:

#include<bits/stdc++.h>
#define debug(x) cout << "[" << #x <<": " << (x) <<"]"<< endl
#define clr(a,b) memset((a),b,sizeof(a))
#define rep(i,a,b) for(int i = a;i < b;i ++)
#define pb push_back
#define MP make_pair
#define LL long long
#define INT(t) int t; scanf("%d",&t)
#define LLI(t) LL t; scanf("%I64d",&t)

using namespace std;

const int maxn = 1e6 + 10;
int a[maxn];
int dp[maxn];
int pre[maxn];

int main()
{
    int m;
    while(~scanf("%d",&m)){
        INT(n);
        rep(i,1,n + 1) scanf("%d",&a[i]);
        clr(dp,0); clr(pre,0);
        int maxx;
        rep(i,1,m + 1){
            maxx = -0x3f3f3f3f;
            rep(j,i,n + 1){
                dp[j] = max(dp[j - 1],pre[j - 1]) + a[j];
                pre[j - 1] = maxx;             ///把前一轮的最大值赋给pre;
                maxx = max(dp[j],maxx);
                printf("%d ",dp[j]);
            }
        }
        printf("%d\n",maxx);
    }
    return 0;
}

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值