HDU 1024


Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19516    Accepted Submission(s): 6436


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
 

Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
 

Output
Output the maximal summation described above in one line.
 

Sample Input
      
      
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

Sample Output
      
      
6 8
Hint
Huge input, scanf and dynamic programming is recommended.

/*
 dp[i][j] 为前 j 个数字分成 i 段的最大和 .


转移方程为 :


dp[i][j]=max(dp[i][j-1],max(dp[i-1][k]))+a[j](i-1<=k<=j-1)


其表达的意义就两个不同的决策 : 前者表示与 j-1 所在的一段合并成一段 , 后者表示以


a[j] 为首开始第 i 段


滚动数组节约空间  
*/


#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
 // 理解好pre[]数组的用途
int dp[1000005];
int pre[1000005];
int a[1000005]={0};
int main()
{
    int m;int n;
    while( scanf("%d%d",&m,&n)!=EOF )
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);

        memset(dp,0,sizeof(dp));
        memset(pre,0,sizeof(pre));
        int temp;
        for(int i=1;i<=m;i++)
        {
            temp=-100000000;
        for(int j=i;j<=n;j++)
        {
            dp[j]=max(dp[j-1]+a[j],pre[j-1]+a[j]);
            pre[j-1]=temp;
            temp=max(dp[j],temp);
        }
        }
        printf("%d\n",temp);
    }
    return 0;
}










  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值