HDU 1712 (分组背包入门题)

ACboy needs your help

ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit? 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has. 
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j]. 
N = 0 and M = 0 ends the input. 

Output

For each data set, your program should output a line which contains the number of the max profit ACboy will gain. 

Sample Input

2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0

Sample Output

3
4
6

 

题意:给一个 n * m 的矩阵,i, j 代表第 i 门课程学 j 天,其值代表获得的价值,最后问 m 天内,能够获得的最大价值。

思路:裸的 分组背包模版题,很显然,对于每一课程 i , 只能选择一个 j 进行学习。

对于 01 背包,假设每一个物品都属于一组,而分组背包就是  的一组物品 就相当于 01 背包的一个物品, 所以 分组背包 可以很简单的用 01 背包理解。

下面看模版伪代码:


for i,所有的组                  // 所有的组,也就是理解为 01 背包所有的物品
    for v=V..0                // 容量 依旧是 容量,逆序的原因和 01 逆序一样
        for j,所有的j属于组i     // 最后多一个循环,遍历这一个组
            f[v]=max{f[v],f[v-c[i][j]]+w[i][j]}  // c[i][j] 表示这个组里的物品的体积大小,w[i][j] 表示这个组里的物品的 价值

 

AC代码:

#include<bits/stdc++.h>
#define debug(x) cout << "[" << #x <<": " << (x) <<"]"<< endl
#define pii pair<int,int>
#define clr(a,b) memset((a),b,sizeof(a))
#define rep(i,a,b) for(int i = a;i < b;i ++)
#define pb push_back
#define MP make_pair
#define LL long long
#define INT(t) int t; scanf("%d",&t)
#define LLI(t) LL t; scanf("%I64d",&t)

using namespace std;

const int maxn = 150;
int a[maxn][maxn];
int dp[maxn];
int n,m;

int main()
{
    while(~scanf("%d%d",&n,&m)){
        if(n + m == 0) break;
        memset(dp,0,sizeof(dp));
        rep(i,1,n + 1)
            rep(j,1,m + 1)
                scanf("%d",&a[i][j]);
        rep(i,1,n + 1)
            for(int j = m;j >= 0;j --)
                rep(k,1,j + 1)
                    dp[j] = max(dp[j],dp[j - k] + a[i][k]);
        printf("%d\n",dp[m]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值