BestCoder 2nd Anniversary - 1001 Oracle

24 篇文章 0 订阅

BestCoder 2nd Anniversary - 1001 Oracle

Accepts: 631 Submissions: 2576

Problem Description
There is once a king and queen, rulers of an unnamed city, who have three daughters of conspicuous beauty.

The youngest and most beautiful is Psyche, whose admirers, neglecting the proper worship of the love goddess Venus, instead pray and make offerings to her. Her father, the king, is desperate to know about her destiny, so he comes to the Delphi Temple to ask for an oracle.

The oracle is an integer n n without leading zeroes.

To get the meaning, he needs to rearrange the digits and split the number into two positive integers without leading zeroes, and their sum should be as large as possible.

Help him to work out the maximum sum. It might be impossible to do that. If so, print Uncertain.

Input
The first line of the input contains an integer T T (1 \le T \le 10) (1≤T≤10), which denotes the number of test cases.

For each test case, the single line contains an integer n n (1 \le n < 10 ^ {10000000}) (1≤n<10
​10000000
​​ ).

Output
For each test case, print a positive integer or a string Uncertain.

Sample Input
3
112
233
1

Sample Output
22
35
Uncertain

Hint

In the first example, it is optimal to split 112 112 into 21 21 and 1 1, and their sum is 21 + 1 = 22 21+1=22.

In the second example, it is optimal to split 233 233 into 2 2 and 33 33, and their sum is 2 + 33 = 35 2+33=35.

In the third example, it is impossible to split single digit 1 1 into two parts.

题意:把一串数分为两部分正数,要求和值最大,否则,输出”Uncertain”
分开判断 一位数、两位数,多位数则判断只有一位数不为0的情况,然后进行处理:sort升序排序,只要形成组合 sum = 最大的数+最小的正数【一位数不为0】

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <ctime>
#include <set>
#include <map>
#include <cmath>
using namespace std;
const int maxn = 10000100;
int n, m, k;
char s[maxn],a[maxn];
int main(){
    scanf("%d",&n);
    while(n--){
        memset(a,'\0',sizeof(a));
        scanf("%s",s);
        int len = strlen(s);
        if(len==1){//一位数 
            printf("Uncertain\n");
            continue;
        }
        if(len==2 ){//两位数 
            if(s[0]=='0'||s[1]=='0') printf("Uncertain\n");
            else printf("%d\n",s[0]-'0'+s[1]-'0');
            continue;
        }
        sort(s,s+len);//升序
        k = 0;
        int flag = 1;
        int si = -1;
        int cnt0 = 0;
        for(int i=0;i<len;i++){
            if(s[i]!='0' && flag){
                si = i;//第一次不为0 
                flag = 0;
                continue;
            }
            if(s[i]=='0')cnt0++;
            a[k++] = s[i];
        }
        if(cnt0>=len-1) {//只有一个不为0的数 
            printf("Uncertain\n");
            continue;
        }
        a[0] += s[si]-'0';
        if(a[0] > '9'){
            a[0] -= 10;
            a[1] += 1;
        }
        m = k;
        for(int i=1;i<k;i++){
            if(i==k-1&&a[i]>'9') {
                m++;
                a[i] -= 10;
                a[i+1] = '1';
                continue;
            }
            if(a[i] > '9'){
                a[i] -= 10;
                a[i+1] += 1;
            }
        }
        for(int i=m-1;i>=0;i--){
            printf("%c",a[i]);
        }
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值