最经典的最长上升子序列问题【LIS】【垃圾死啦都】

声明:本次博文主要是讲的是关于最长上升子序列的问题,简称【LIS问题】都是一些入门题,板子题,勿喷,具体算法分析请自行百度 即: nlgn 的复杂度

POJ - 3903 - Stock Exchange

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7220 Accepted: 2518

Description

The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for rising trends. Given a sequence of numbers p1, p2,…,pn representing stock prices, a rising trend is a subsequence pi1 < pi2 < … < pik, with i1 < i2 < … < ik. John’s problem is to find very quickly the longest rising trend.

Input

Each data set in the file stands for a particular set of stock prices. A data set starts with the length L (L ≤ 100000) of the sequence of numbers, followed by the numbers (a number fits a long integer).
White spaces can occur freely in the input. The input data are correct and terminate with an end of file.

Output

The program prints the length of the longest rising trend.
For each set of data the program prints the result to the standard output from the beginning of a line.

Sample Input

6
5 2 1 4 5 3
3
1 1 1
4
4 3 2 1

Sample Output

3
1
1

Hint

There are three data sets. In the first case, the length L of the sequence is 6. The sequence is 5, 2, 1, 4, 5, 3. The result for the data set is the length of the longest rising trend: 3.

Source

Southeastern European Regional Programming Contest 2008
题意: LIS的板子题,就是求一个数列的最长上升子序列,严格递增哦

#include <cstdio>
#include <algorithm>
#include <iostream>
using namespace std;

const int N = 1e5 + 10;
int a[N],b[N];

int binary(int x,int rr){
    int l = 0,r = rr,ans;
    while(l <= r){
        int mid = l + r >> 1;
        if(b[mid] >= x) ans = mid,r = mid  - 1;
        else l = mid + 1;
    }
    return ans;
}

int main(){
    ios_base::sync_with_stdio(0);
    int n;
    while(cin>>n){
        for(int i = 1; i <= n;i++){
            cin>>a[i];
        }
        int len = 1;
        b[1] = a[1];
        for(int i = 2;i <= n;i++){
            if(a[i] > b[len]){
                b[++len] = a[i];
            }
            else {
                int t = binary(a[i],len);//也可以用c++自带的lower_pound,自写也可以
                b[t] = a[i];
            }
        }
        cout<<len<<endl;
    }
    return 0;
}
  • 如有错误或遗漏,请私聊下UP,ths
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值