AtCoder Beginner Contest 085 D - Katana Thrower【贪心】

AtCoder Beginner Contest 085 D - Katana Thrower

Time limit : 2sec / Memory limit : 256MB

Score : 400 points

Problem Statement

You are going out for a walk, when you suddenly encounter a monster. Fortunately, you have N katana (swords), Katana 1, Katana 2, …, Katana N, and can perform the following two kinds of attacks in any order:

Wield one of the katana you have. When you wield Katana i (1≤i≤N), the monster receives ai points of damage. The same katana can be wielded any number of times.
Throw one of the katana you have. When you throw Katana i (1≤i≤N) at the monster, it receives bi points of damage, and you lose the katana. That is, you can no longer wield or throw that katana.
The monster will vanish when the total damage it has received is H points or more. At least how many attacks do you need in order to vanish it in total?

Constraints
1≤N≤105
1≤H≤109
1≤ai≤bi≤109
All input values are integers.

Input

Input is given from Standard Input in the following format:

N H
a1 b1
:
aN bN

Output

Print the minimum total number of attacks required to vanish the monster.

Sample Input 1

1 10
3 5

Sample Output 1

3
You have one katana. Wielding it deals 3 points of damage, and throwing it deals 5 points of damage. By wielding it twice and then throwing it, you will deal 3+3+5=11 points of damage in a total of three attacks, vanishing the monster.

Sample Input 2

2 10
3 5
2 6

Sample Output 2

2
In addition to the katana above, you also have another katana. Wielding it deals 2 points of damage, and throwing it deals 6 points of damage. By throwing both katana, you will deal 5+6=11 points of damage in two attacks, vanishing the monster.

Sample Input 3

4 1000000000
1 1
1 10000000
1 30000000
1 99999999

Sample Output 3

860000004

Sample Input 4

5 500
35 44
28 83
46 62
31 79
40 43

Sample Output 4

9
题意: 给你n个武士刀,每个刀都有两个技能,一个是普通攻击,可以打出伤害为 ai ,或者第二技能伤害为 bi ,一旦使用了这个技能,这个刀就不能用了,给你怪的生命值,问你使用技能的最少次数

分析: 简单贪心下,直接选出所有的a技能中最大的为max_a,去掉b技能中比max_a 小的,我们可以先用剩下的b技能的武士刀中,看看能否将怪杀死,不能的话剩下的都用max_a技能即可,直接向上取整。

参考代码

#include<bits/stdc++.h>

using namespace std;

#define ll long long

const int N = 1e5 + 10;

struct E{
    ll x,y;

}a[N];

bool cmp1(E e1,E e2) {
    return e1.y > e2.y;
}

bool cmp2(E e1,E e2) {
    return e1.x > e2.x;
}

int main(){
    ios_base::sync_with_stdio(0);
    int n,s;cin>>n>>s;
    for(int i = 0;i < n;i++) {
        cin>>a[i].x>>a[i].y;
    }
    sort(a,a+n,cmp2);
    ll max_x = a[0].x;
    sort(a,a+n,cmp1);
    int len_t = n;
    for(int i = 0;i < n;i++) {
        if(a[i].y < max_x) {
            len_t = i;
            break;
        }
    }
    ll sum = 0;
    int res = 0;
    for(int i = 0;i < len_t;i++) {
        sum += a[i].y;
        res++;
        if(sum >= s) {
            cout<<res<<endl;
            return 0;
        }
    }
    s -= sum;
    res += ceil(s*1.0/max_x);
    cout<<res<<endl;
    return 0;
}
  • 如有错误或遗漏,请私聊下UP,ths
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值