PAT(甲)1092 To Buy or Not to Buy (20 分)

Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.

For the sake of simplicity, let's use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

figbuy.jpg

Figure 1

Input Specification:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:

For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

Sample Input 1:

ppRYYGrrYBR2258
YrR8RrY

Sample Output 1:

Yes 8

Sample Input 2:

ppRYYGrrYB225
YrR8RrY

Sample Output 2:

No 2

note:给定两个字符串,判断能否从第一个字符串里拼出第二个字符串,每个字符只能用一次,如果能,则输出多余字符个数。如果不能,则输出缺少字符个数。

思路:利用map,初始化两个map,第一个存储第一个字符串中每个字符出现的次数,第二个用以判断该字符是否在在第一字符串中出现过,然后对第二个字符串每个字符判别。

#include<iostream>
#include<string>
#include<map>
using namespace std;

int main(){
	// freopen("F:\\PAT test\\test.txt","r",stdin);
	string s1, s2;
	cin >> s1 >> s2;
//	cout << s1 <<" "<<s2;
	map<char, int> m1;
	map<char, bool> m2;
	for(int i = 0; i < s1.length(); i++){
		m1[s1[i]]++;
		m2[s1[i]] = true;
	}
	bool flag = true;
	int cnt = 0;
	for(int i = 0; i < s2.length(); i++){
		if(m2[s2[i]] == true){
			if(m1[s2[i]] > 0){
				m1[s2[i]]--;
			}else if(m1[s2[i]] == 0){
				flag = false;
				cnt++;
			}
		}else{
			cnt++;
			flag = false;
		}
	}
	if(flag == true){
		cout << "Yes " << s1.length() - s2.length();
	}else{
		cout << "No " << cnt;
	}
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值