POJ 1201 Intervals 差分约束系统

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 27889 Accepted: 10743

Description

You are given n closed, integer intervals [ai, bi] and n integers c1, …, cn.
Write a program that:
reads the number of intervals, their end points and integers c1, …, cn from the standard input,
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,…,n,
writes the answer to the standard output.

Input

The first line of the input contains an integer n (1 <= n <= 50000) – the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,…,n.

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output

6

Source

Southwestern Europe 2002


题目大意:

给定一个长度为N的序列,序列中所有数字都是非负数且不相同
题目将会以一些三元组[a,b,c]对这个数列进行描述,表示序列中数值在[a,b]之间的数字至少有ci个 询问使得所有条件都成立的序列长度最短是多少

题解:

查分约束系统裸题,直接按照sum来建边就可以了
先把题目所给条件表示成不等式。
定义S数组:S[i]表示序列中数值在[0,i]内的数字的个数
定义maxN:整个序列中的最大值。(相当于b)
那么对于一个三元组[a,b,c],就可以被写成S[b]-S[a-1]≥c
同时,这个题还有两个显然的隐藏条件:S[i]≥S[i-1],S[i]≤S[i-1]+1
这些条件会连成很多链,像这样:S[B]-S[A]≥x,S[C]-S[B]≥y,S[D]-S[C]≥z……
那么我们就是要求满足所有这样不等式的最小的S[maxN]

我们把条件变一变,把每个数值看作一个点。
那么对于S[b] ≥c+S[a-1],就可以看作 a-1向b连了一条边,边权为c。
对于S[i]≥S[i-1]+0,可以看作从i-1向i连了一条边权为0的边。
对于S[i]≤S[i-1]+1,因为需要保证不等式符号方向一致,因此化成 S[i-1]≥S[i]-1的形式,可以看做 i 向 i-1连了一条边权为-1的边
因为我们所求的S[maxN]需要符合所有约束条件,并且还要求最小。那么也就是说,S[maxN]的值就是最长的那条链上的和。
到了这里,解法就比较明显了。按照上述方法建边,初始化dis数组为0。从0开始跑最长路,最后dis[maxN]即为所求

#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
using namespace std;

const int MAXN = 100000;
int n, m, tail, dis[MAXN], head[MAXN];
struct Line{ int to, nxt, flow; }line[ MAXN * 2 ];
void add_line( int from, int to, int flow ) {
    line[++tail].nxt = head[from];
    line[tail].to = to;
    line[tail].flow = flow;
    head[from] = tail;
}

bool vis[MAXN];

void SPFA() {
    memset( dis, -1, sizeof( dis ) );
    queue<int>q; while( !q.empty() ) q.pop();
    q.push(0); dis[0] = 0; vis[0] = true;
    while( !q.empty() ) {
        int u = q.front(); vis[u] = false; q.pop();
        for( register int i = head[u]; i; i = line[i].nxt ) {
            int v = line[i].to;
            if( dis[v] < dis[u] + line[i].flow ) {
                dis[v] = dis[u] + line[i].flow;
                if( !vis[v] ) { vis[v] = true; q.push(v); }
            }
        }
    }
}

int main( ) {
    scanf( "%d", &n ); int l, r, c;
    for( register int i = 1; i <= n; i++ ) {
        scanf( "%d%d%d", &l, &r, &c );
        add_line( l - 1 , r, c );
    }
    for( register int i = 1; i <= 50000; i++ )     add_line( i, i - 1, -1 );
    for( register int i = 0; i <= 50000 - 1; i++ ) add_line( i, i + 1, 0 );
    SPFA();
    printf( "%d\n", dis[50000] );
    return 0;
}
Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值