HDU 4738 Caocao's Bridges 求桥 诸葛亮带着炸弹跑路了

Description

Caocao was defeated by Zhuge Liang and Zhou Yu in the battle of Chibi. But he wouldn’t give up. Caocao’s army still was not good at water battles, so he came up with another idea. He built many islands in the Changjiang river, and based on those islands, Caocao’s army could easily attack Zhou Yu’s troop. Caocao also built bridges connecting islands. If all islands were connected by bridges, Caocao’s army could be deployed very conveniently among those islands. Zhou Yu couldn’t stand with that, so he wanted to destroy some Caocao’s bridges so one or more islands would be seperated from other islands. But Zhou Yu had only one bomb which was left by Zhuge Liang, so he could only destroy one bridge. Zhou Yu must send someone carrying the bomb to destroy the bridge. There might be guards on bridges. The soldier number of the bombing team couldn’t be less than the guard number of a bridge, or the mission would fail. Please figure out as least how many soldiers Zhou Yu have to sent to complete the island seperating mission.

Input

There are no more than 12 test cases.

In each test case:

The first line contains two integers, N and M, meaning that there are N islands and M bridges. All the islands are numbered from 1 to N. ( 2 <= N <= 1000, 0 < M <= N 2 )

Next M lines describes M bridges. Each line contains three integers U,V and W, meaning that there is a bridge connecting island U and island V, and there are W guards on that bridge. ( U ≠ V and 0 <= W <= 10,000 )

The input ends with N = 0 and M = 0.

Output

For each test case, print the minimum soldier number Zhou Yu had to send to complete the mission. If Zhou Yu couldn’t succeed any way, print -1 instead.

Sample Input

3 3
1 2 7
2 3 4
3 1 4
3 2
1 2 7
2 3 4
0 0

Sample Output

-1
4


题目翻译:

这道题就是说求桥,在所有桥里求权值最小的,其中的权值表示这条路上有多少个敌人,如果有5个敌人,就至少派五个人,但是注意如果没有敌人,还是需要派一个人去,我们派人去的目的是炸桥,这里的桥是图论中定义的桥,如果有多个桥,则派人去敌人防守最少的,也就是权值最小的


题解:

求桥的板子题!!!这道题的代码是板子,记得多复习233,求桥有个操作是传边,我们可以从u到v再到u,因为有重边,所以我们传边,不走已经走过的边就可以了


#include <cstdio>
#include <iostream>
#include <cstring>

using namespace std;

const int MAXN = 1000 + 10;
const int MAXM = 1000 * 1000 + 10;
int n, m, cnt, tail, timer;
int head[MAXN], dfn[MAXN], low[MAXN], ans;
bool ARI[MAXN][MAXN];

void init( ) {
    memset( head, 0, sizeof( head) );
    memset( dfn, 0, sizeof( dfn ) );
    memset( low, 0, sizeof( low ) );
    tail = 1; timer = 0; cnt = 0; ans = 0x7fffffff;
}
struct Line{ int to, nxt, flow; }line[MAXM];
void add_line( int from, int to, int flow ) {
    line[++tail].to = to;
    line[tail].nxt = head[from];
    line[tail].flow = flow;
    head[from] = tail; 
}
void Tarjan( int u, int fa ) {
    timer++; low[u] = dfn[u] = timer; cnt++;
    for( register int i = head[u]; i; i = line[i].nxt ) {
        int v = line[i].to;
        if( i == ( fa ^ 1 ) ) continue;
        if( !dfn[v] ) {
            Tarjan( v, i );
            low[u] = min( low[u], low[v] );
            if( low[v] > dfn[u] ) ans = min( ans, line[i].flow );
        } else low[u] = min( low[u], dfn[v] ); 
    }
}
int main( ) {
    while( scanf( "%d%d", &n, &m ) != EOF && n != 0 && m != 0 ) {
        init( );
        for( register int i = 1; i <= m; i++ ) { int u, v, w;
            scanf( "%d%d%d", &u, &v, &w );
            add_line( u, v, w ); add_line( v, u, w );
        }
        Tarjan( 1, -1 );
        if( cnt != n ) { printf( "0\n" ); continue; }
        if( ans == 0x7fffffff ) {
            printf( "-1\n" ); continue;
        } else if( ans == 0 ) printf( "1\n" );
          else                printf( "%d\n", ans );
    }
    return 0;
}

HDU坑题多


这里写图片描述

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值