2015南阳CCPC D - Pick The Sticks dp

参考:http://www.cnblogs.com/qscqesze/p/4899344.html

D - Pick The Sticks

Time Limit: 1 Sec

Memory Limit: 256 MB
题目连接


Description

The story happened long long ago. One day, Cao Cao made a special order called “Chicken Rib” to his army. No one got his point and all became very panic. However, Cao Cao himself felt very proud of his interesting idea and enjoyed it.

Xiu Yang, one of the cleverest counselors of Cao Cao, understood the command Rather than keep it to himself, he told the point to the whole army. Cao Cao got very angry at his cleverness and would like to punish Xiu Yang. But how can you punish someone because he’s clever? By looking at the chicken rib, he finally got a new idea to punish Xiu Yang.

He told Xiu Yang that as his reward of encrypting the special order, he could take as many gold sticks as possible from his desk. But he could only use one stick as the container.

Formally, we can treat the container stick as an L length segment. And the gold sticks as segments too. There were many gold sticks with different length ai and value vi. Xiu Yang needed to put these gold segments onto the container segment. No gold segment was allowed to be overlapped. Luckily, Xiu Yang came up with a good idea. On the two sides of the container, he could make part of the gold sticks outside the container as long as the center of the gravity of each gold stick was still within the container. This could help him get more valuable gold sticks.

As a result, Xiu Yang took too many gold sticks which made Cao Cao much more angry. Cao Cao killed Xiu Yang before he made himself home. So no one knows how many gold sticks Xiu Yang made it in the container.

Can you help solve the mystery by finding out what’s the maximum value of the gold sticks Xiu Yang could have taken?

Input
The first line of the input gives the number of test cases, T(1≤T≤100). T test cases follow. Each test case start with two integers, N(1≤N≤1000) and L(1≤L≤2000), represents the number of gold sticks and the length of the container stick. N lines follow. Each line consist of two integers, ai(1≤ai≤2000) and vi(1≤vi≤109), represents the length and the value of the ith gold stick.
Output
For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is the maximum value of the gold sticks Xiu Yang could have taken.
Sample Input

4

3 7
4 1
2 1
8 1

3 7
4 2
2 1
8 4

3 5
4 1
2 2
8 9

1 1
10 3

Sample Output

Case #1: 2
Case #2: 6
Case #3: 11
Case #4: 3

HINT

【题意】
给你一个长度为m([1,2000])的长条状容器。
然后我们有n([1,1000])段木棒。
第i段木棒有一个长度a[i].l和价值a[i].v。
我们希望把尽可能大价值的木棒放到容器中,使得所有木棒的重心都在容器内
要求木棒不能重叠。

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<cstring>
using namespace std;


long long dp[2][6005][3];
struct node
{
    int x;
    long long y;
};
node p[1005];
int main()
{
    int t;scanf("%d",&t);
    for(int cas = 1 ; cas <= t; cas++)
    {
        memset(dp,0,sizeof(dp));
        memset(p,0,sizeof(p));
        int n,l;scanf("%d%d",&n,&l);
        long long ans = 0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%lld",&p[i].x,&p[i].y);
            p[i].x*=2;
            ans = max(ans,p[i].y);
        }
        l *= 2;
        int now = 1;
        for(int i=1;i<=n;i++)
        {
            now = 1-now;
            for(int j=0;j<=l;j++)
                for(int k=0;k<3;k++)
                    dp[now][j][k]=dp[1-now][j][k];
            for(int j=l;j>=p[i].x/2;j--)
            {
                for(int k=0;k<3;k++)
                {
                    if(j>=p[i].x)dp[now][j][k]=max(dp[now][j][k],dp[1-now][j-p[i].x][k]+p[i].y);
                    if(k)dp[now][j][k]=max(dp[now][j][k],dp[1-now][j-p[i].x/2][k-1]+p[i].y);
                }
            }
        }
        for(int t=0;t<2;t++)
            for(int i=0;i<=l;i++)
                for(int k=0;k<3;k++)
                    ans = max(dp[t][i][k],ans);
        printf("Case #%d: %lld\n",cas,ans);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值