HDU OJ 3579 Hello Kiki(线性同余方程组的合并求解)

题目:

Hello Kiki

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2187    Accepted Submission(s): 791


Problem Description
One day I was shopping in the supermarket. There was a cashier counting coins seriously when a little kid running and singing "门前大桥下游过一群鸭,快来快来 数一数,二四六七八". And then the cashier put the counted coins back morosely and count again...
Hello Kiki is such a lovely girl that she loves doing counting in a different way. For example, when she is counting X coins, she count them N times. Each time she divide the coins into several same sized groups and write down the group size Mi and the number of the remaining coins Ai on her note.
One day Kiki's father found her note and he wanted to know how much coins Kiki was counting.
 

Input
The first line is T indicating the number of test cases.
Each case contains N on the first line, Mi(1 <= i <= N) on the second line, and corresponding Ai(1 <= i <= N) on the third line.
All numbers in the input and output are integers.
1 <= T <= 100, 1 <= N <= 6, 1 <= Mi <= 50, 0 <= Ai < Mi
 

Output
For each case output the least positive integer X which Kiki was counting in the sample output format. If there is no solution then output -1.
 

Sample Input
  
  
2 2 14 57 5 56 5 19 54 40 24 80 11 2 36 20 76
 

Sample Output
  
  
Case 1: 341 Case 2: 5996
 

Author
digiter (Special Thanks echo)
 

Source
 

Recommend
zhouzeyong   |   We have carefully selected several similar problems for you:   3573  3574  3575  3576  3577 
 


代码:

/***********************************
*                                  *
*    @name:HDU OJ 3579             *
*  @author:npufz                   *
************************************/
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
using namespace std;
long long gcd(long long a,long long b)
{
    return  (b==0)?a:gcd(b,a%b);
}
long long exgcd(long long a,long long b,long long &x,long long &y)
{
    if(b==0){x=1;y=0;return a;}
    long long  d=exgcd(b,a%b,y,x);
    y=y-a/b*x;
    return d;
}
int main()
{
    long long  m[10],i,t,a[10],cnt,n,t1,x,y;
    bool flag;
    cin>>t;
    for(cnt=1;cnt<=t;cnt++)
    {
        scanf("%I64d",&n);
        for(i=0;i<n;i++)
            scanf("%I64d",&m[i]);
        for(i=0;i<n;i++)
            scanf("%I64d",&a[i]);
            flag=true;
        for(i=1;i<n&&flag;i++)
        {
            long long g1;
            if(m[0]<m[i])
             {
                 t1=m[0];m[0]=m[i];m[i]=t1;
                 t1=a[0];a[0]=a[i];a[i]=t1;
             }
            g1=gcd(m[0],m[i]);
            long long lcm;
            lcm=m[0]*m[i]/g1;
            long long c;
            c=(a[0]-a[i]);
            if(c%g1==0)
            {
                exgcd(m[0],m[i],x,y);
                a[0]=(a[0]-c/g1*x*m[0]);
                m[0]=lcm;
                a[0]=(a[0]%m[0]+m[0])%m[0];
            }
            else flag=false;
        }
        if(flag==false) printf("Case %I64d: %d\n",cnt,-1);
        else
        {
            if(a[0]==0)
            printf("Case %I64d: %I64d\n",cnt,m[0]);
            else  printf("Case %I64d: %I64d\n",cnt,a[0]);
        }
}
return 0;
}

反思:题目是解一组线性同余方程组,用合并同余方程组的方法可以进行求解,这里由于各个除数不是互质的,因此不可以直接套用中国剩余定理,注意如果余数是零,那么输出不可以是零,还有就是用扩展欧几里得解二元一次不定方程的整数解时,注意数字的先后顺序,以免解错,一开始由于在交换两个数据手残大打时错了,就一直以为解方程错了,好久才调试出来,伤死了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值