Given a circle sequence A[1],A[2],A[3]......A[n]. Circle sequence means the left neighbour of A[1] is A[n] , and the right neighbour of A[n] is A[1].
Now your job is to calculate the max sum of a Max-K-sub-sequence. Max-K-sub-sequence means a continuous non-empty sub-sequence which length not exceed K.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases.
Then T lines follow, each line starts with two integers N , K(1<=N<=100000 , 1<=K<=N), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output a line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the minimum start position, if still more than one , output the minimum length of them.
Sample Input
4
6 3
6 -1 2 -6 5 -5
6 4
6 -1 2 -6 5 -5
6 3
-1 2 -6 5 -5 6
6 6
-1 -1 -1 -1 -1 -1
Sample Output
7 1 3
7 1 3
7 6 2
-1 1 1
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
const int INF = 0x7fffffff;
const int maxn = 1e6 + 10;
int a[maxn], sum[maxn];
int read() {
int f = 1, i = 0;
char ch = getchar();
while (ch < '0' || ch > '9') {
if (ch == '-') f = -1;
ch = getchar();
}
while (ch >= '0' && ch <= '9') {
i = i*10 + (ch - 48);
ch = getchar();
}
return i*f;
}
int main(void) {
int t;
scanf ("%d", &t);
while (t--) {
int n, k;
scanf ("%d %d", &n, &k);
sum[0] = 0;
register int i;
for (i = 1; i <= n; i+=4) {
if (i+4 > n) break;
scanf("%d %d %d %d", &a[i], &a[i+1], &a[i+2], &a[i+3]);
a[i+n] = a[i], a[i+n+1] = a[i+1], a[i+n+2] = a[i+2], a[i+n+3] = a[i+3];
sum[i] = sum[i-1] + a[i], sum[i+1] = sum[i] + a[i+1];
sum[i+2] = sum[i+1] + a[i+2], sum[i+3] = sum[i+2] + a[i+3];
}
for (; i <= n; ++i) {
scanf ("%d", &a[i]);
a[i+n] = a[i];
sum[i] = sum[i-1] + a[i];
}
int m = 2*n;
for (i = n+1; i <= m; i+=3) {
if (i+3 > m) break;
sum[i] = sum[i-1] + a[i], sum[i+1] = sum[i] + a[i+1], sum[i+2] = sum[i+1] + a[i+2];
}
for (; i <= m; ++i) {
sum[i] = sum[i-1] + a[i];
}
deque<int> q;
int st, ed, ans = -INF;
m = n+k-1;
for (i = 1; i <= m; ++i) {
while (!q.empty() && sum[i-1] < sum[q.back()])
q.pop_back();
while (!q.empty() && q.front() < i-k)
q.pop_front();
q.push_back(i-1);
if (sum[i] - sum[q.front()] > ans) {
ans = sum[i] - sum[q.front()];
st = q.front() + 1;
ed = i;
}
}
if (ed > n) ed -= n;
printf("%d %d %d\n", ans, st, ed);
}
return 0;
}