Critical Links UVA - 796 (tarjan+割边)

Critical Links

 UVA - 796 

In a computer network a link L, which interconnects two servers, is considered critical if there are at least two servers A and B such that all network interconnection paths between A and B pass through L. Removing a critical link generates two disjoint sub–networks such that any two servers of a sub–network are interconnected. For example, the network shown in figure 1 has three critical links that are marked bold: 0 -1, 3 - 4 and 6 - 7. Figure 1: Critical links It is known that: 1. the connection links are bi–directional; 2. a server is not directly connected to itself; 3. two servers are interconnected if they are directly connected or if they are interconnected with the same server; 4. the network can have stand–alone sub–networks. Write a program that finds all critical links of a given computer network. Input The program reads sets of data from a text file. Each data set specifies the structure of a network and has the format: no of servers server0 (no of direct connections) connected server . . . connected server . . . serverno of servers (no of direct connections) connected server . . . connected server The first line contains a positive integer no of servers(possibly 0) which is the number of network servers. The next no of servers lines, one for each server in the network, are randomly ordered and show the way servers are connected. The line corresponding to serverk, 0 ≤ k ≤ no of servers − 1, specifies the number of direct connections of serverk and the servers which are directly connected to serverk. Servers are represented by integers from 0 to no of servers − 1. Input data are correct. The first data set from sample input below corresponds to the network in figure 1, while the second data set specifies an empty network. Output The result of the program is on standard output. For each data set the program prints the number of critical links and the critical links, one link per line, starting from the beginning of the line, as shown in the sample output below. The links are listed in ascending order according to their first element. The output for the data set is followed by an empty line. Sample Input 8 0 (1) 1 1 (3) 2 0 3 2 (2) 1 3 3 (3) 1 2 4 4 (1) 3 7 (1) 6 6 (1) 7 5 (0) 0 Sample Output 3 critical links 0 - 1 3 - 4 6 - 7 0 critical links

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <string>
#include <cmath>
using namespace std;
const int N = 2e3 + 7;
const int M = 1e5 + 7;
pair<int, int> p[M]; //割边 
int tot; //割边数 
int head[N], en;
struct Edge {
	int u, v, to;
} e[M];
bool cmp (const pair<int, int> &a, const pair<int, int> &b) {
	if (a.first == b.first) return a.second < b.second;
	return a.first < b.first;	
}
void addedge(int u, int v) {
	e[++en].u = u;
	e[en].v = v;
	e[en].to = head[u];
	head[u] = en;
}
int dfn[N], low[N], deep;
void tarjan(int u, int father) {
	low[u] = dfn[u] = ++deep;
	for (int i = head[u]; ~i; i = e[i].to) {
		int v = e[i].v;
		if (!dfn[v]) {
			tarjan(v, u);
			low[u] = min(low[u], low[v]);
			/*if (low[v] > dfn[u]) { //割边 
				p[tot].first = u, p[tot++].second = v;
			}*/
		} else if (v != father){ //防止u再遍历它的父节点//双向边 
			low[u] = min(low[u], dfn[v]);
		}
	}
}
void init() {
	memset(head, -1, sizeof(head));
	memset(dfn, 0, sizeof(dfn));
	memset(low, 0, sizeof(low));
	en = deep = tot = 0;
}
int main() {
	
	int n;
	while (~scanf ("%d", &n)) {
		int u, v, m;
		init();
		for (int i = 1; i <= n; ++i) {
			scanf ("%d (%d)", &u, &m);
			while (m--) {
				scanf ("%d", &v);
				addedge(u, v);
			}
		}
		for (int i = 0; i < n; ++i) {
			if (!dfn[i]) {
				tarjan(i, -1);
			}
		}
		for (int i = 1; i <= en; ++i) {
			if (low[e[i].v] > dfn[e[i].u]) {
				if (e[i].u > e[i].v) swap(e[i].u, e[i].v);
				p[tot].first = e[i].u, p[tot++].second = e[i].v;
			}
		}
		sort(p, p + tot, cmp);
		printf ("%d critical links\n", tot);
		for (int i = 0; i < tot; ++i) {
			printf ("%d - %d\n", p[i].first, p[i].second);
		}
		puts("");
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值