1063 Set Similarity 25

1063 Set Similarity 25

问题描述

Given two sets of integers, the similarity of the sets is defined to be N c / N t × 100 {N_c}/{N_t}×100% Nc/Nt×100, where N c N_c Nc is the number of distinct common numbers shared by the two sets, and N t N_t Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N ( ≤ 50 ) N (≤50) N(50) which is the total number of sets. Then N N N lines follow, each gives a set with a positive M ( ≤ 1 0 4 ) M (≤10^4) M(104) and followed by M M M integers in the range [ 0 , 1 0 9 ] [0,10^9] [0,109]. After the input of sets, a positive integer K ( ≤ 2000 ) K (≤2000) K(2000) is given, followed by K K K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N N N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

源码

#include <iostream>
#include <cstdio>
#include <set>
using namespace std;

int main()
{
    int N;
    scanf("%d", &N);
    set<int> sets[N];
    for (int i = 0; i < N; i++)
    {
        int M, input;
        scanf("%d", &M);
        for (int j = 0; j < M; j++)
        {
            scanf("%d", &input);
            sets[i].insert(input);
        }
    }

    scanf("%d", &N);
    int s1, s2;
    for (int i = 0; i < N; i++)
    {
        scanf("%d %d", &s1, &s2);
        s1--;s2--;
        set<int> set_union(sets[s1]), set_sec;
        set_union.insert(sets[s2].begin(), sets[s2].end());

        for(auto s = sets[s1].begin(); s != sets[s1].end(); s++)
        {
            if(sets[s2].find(*s) != sets[s2].end())
            {
                set_sec.insert(*s);
            }
        }
        printf("%.1f%%\n", (double)set_sec.size()/set_union.size()*100);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值