nzyalj的博客

行者常至

博客搬家啦!!

重要的事说三遍 新地址 http://blog.schwarzeni.com/ 新地址 http://blog.schwarzeni.com/ 新地址 http://blog.schwarzeni.com/ 这个博客可能就不怎么会更新啦

2018-05-25 20:34:24

阅读数:68

评论数:2

解决Parallel Tools无法在Ubuntu18.04发行版中安装的问题的一个方案

这是老外给的,直接修改程序中的源文件中的代码 因为解决方案会随时更新,这里就不搬运了,直接给原文链接,照着做就可以了 如果共享文件夹失效的话记得看文章的最后几行,执行一下那个命令 亲测可用,环境是PD13,Ubuntu18.04 ...

2018-10-31 23:04:24

阅读数:146

评论数:0

致屌丝的我

大四开始了,已经到了考研的冲刺阶段,但是因为暑假时候没认真复习所以导致进度严重落后,而东大今年计算机招的考生格外地少,同时,学院保研人的名单和东大推免的名单都出来了,不知怎么回事,看到这些都会让我的心里十分烦躁,对,超级烦躁,心里总是想:要是我的名字在里面该多好,要是不用考研那可以省多少钱多少时间...

2018-09-19 20:26:11

阅读数:42

评论数:1

解决VMware运行Ubuntu无法跨系统复制粘贴的问题

环境 MacOS 10.13.4 VMware Fusion Pro 10.1.1 Ubuntu 16.04 LTS 问题 无法在宿主环境与虚拟环境之间复制粘贴 解决方案 在Ubuntu的命令行中执行一下命令 sudo apt-get autoremove op...

2018-05-12 08:14:33

阅读数:4808

评论数:8

使用arp欺骗进行同一局域网内的抓包

环境 操作系统: MacOS 10.13.4 包管理工具:MacPorts 2.4.4 arp欺骗工具:arpspoof 2.4 抓取局域网内的IP地址的工具:nmap 7.70 抓包工具:Wireshark 2.4.3 前言 本来是想了解如何抢占带宽的,搜到了这么一篇文章:如何...

2018-05-07 16:07:05

阅读数:865

评论数:0

Django+Ngnix+Gunicorn+Mysql部署Centos的坑

环境配置 Centos 7 Python 3.6.5 Virtualenvwrapper 4.8.2 Django 2.0.5 Mysql 5.7.22 Ngnix 1.12.2 Gunicorn 19.8.1 注:这并不是什么教程 python虚拟环境配置 Virtualen...

2018-05-05 11:52:48

阅读数:155

评论数:0

解决Linux(Ubuntu)下Oracle12中文乱码的问题

起因 Mac上为了方便使用Oracle使用了Docker中大神制作的Oracle镜像,但是当表中出现中文数据时出现了乱码的情况(全是’???’) 分析 先从操作系统层面分析,Linux系统本身是否不支持中文 输入如下命令查看是否有zh_CN.utf8 locale -a 如...

2018-04-23 19:21:22

阅读数:378

评论数:0

不能将模版类的定义与实现分别写在header文件和cpp文件中

环境参数 macOS 10.13.3 clion 2017.3 cmake 3.9 起因 在编写cpp程序时将一个模版类的定义写在了header文件中,而其方法的实现写在了另一份cpp文件中,结果使用IDE运行时报错,“Undefined symbols for architertu...

2018-02-22 12:07:17

阅读数:241

评论数:0

为docker的mysql容器创建用户

环境 macOS 10.13.3 docker 17.12.0-ce mysql容器信息 CONTAINER ID: 478bbac9137b IMAGE: mysql:5.7.21 PORTS: 0.0.0.0:3306->3306/tcp NAMES: mysql.5.7.2...

2018-01-30 12:42:49

阅读数:1740

评论数:0

使用docker的mysql镜像

环境 macOS 10.13.2 docker 17.12.0 mysql镜像版本 5.7.21 确保docker运行 安装mysql镜像 到官网查看mysql镜像相关信息,使用docker指令pull安装 docker pull mysql:5.7.21 使用do...

2018-01-26 22:21:03

阅读数:3693

评论数:0

GO的工程结构以及与Intellij IDEA 的配合

前言马上准备放假了,准备把Go学学,之前也断断续续看过,其中最搞不清的就是Go的工程结构以及对包的引用,今天又结合着官网的文档: How to Write Go Code学习了一遍,在此做一个总结工程大体结构├── bin # 可执行的二进制文件,由 go install 或 go...

2018-01-15 14:03:26

阅读数:2892

评论数:0

Android Studio 自带模拟器root时:adbd cannot run as root in production builds

如图:请检查模拟器的Android版本,如下图红圈:括号里为 (Google Play) 的版本无法root,只用为 (Google APIs) 的才可以,重新下载正确的版本即可参考 StackOverflow: ADB root is not working on emulator

2017-12-19 10:17:16

阅读数:1381

评论数:1

python2.x基础学习笔记(一)

python文件格式第一行指定脚本运行环境的python路径(可选)第二行指定文件编码需要添加模块注释(一个文件就是一个模块),方便使用 __doc__ 调取需要为每个函数与类添加注释,使用三引号,方便使用 __doc__ 调取使用四个空格的缩进,不需要花括号#!/Users/nizhenyang...

2017-11-29 10:11:47

阅读数:135

评论数:0

第一份Makefile

前言因为比较喜欢Javascript,而其引擎是用C++写的,而且最近打算学习算法,所以重拾C++,在学校还是大一下学习学的,现在都大三上学习快结束了,虽然这学期学了VC++,但还是觉得忘的差不多了……环境GUN make v3.81g++ v4.2.1MacOS (Linux也可以,Window...

2017-11-23 15:37:26

阅读数:124

评论数:0

Webpack搭建完整Typescript开发环境

前言IDE提供了强大的纠错与补全能力,但是对于从开发时的编程语言实时转译,提供开发本地服务器以及自动刷新,到转为生产环境代码的编译,压缩,混淆代码以及打包,还是交给一些第三方工具的吧,对,我说的就是Typescript代替Javascript进行前端开发,第三方工具就说的是神器webpack。在此...

2017-10-21 21:12:51

阅读数:7012

评论数:1

《你不知道的javascript》阅读笔记(上卷第一部分)

一周的进度为了更好地了解javascript这门我比较喜欢的编程语言,我选择了《你不知道的javascript》这一本书来进行学习,先从上卷开始学习,一周下来把第一部分”作用域和闭包”以及第二部分“this和对象原型”的一到三章学习完毕,并做了一些笔记,一周将过,准备对学习的内容进行反思.java...

2017-09-24 21:18:08

阅读数:162

评论数:0

Android Studio sync build.gradle 出现:Failed to resolve: com.android.support:appcompat 问题

在使用 Android Studio 初始化一个project的后需要 sync 一下 app/build.gradle 文件,但是会报出诸如下面的错误:Failed to resolve: com.android.support:appcompat-v7:26.0.0 这是什么原因呢?如果你的A...

2017-09-21 14:55:38

阅读数:3394

评论数:0

KOA初体验

起因最近在看《第一行代码Android》,看到网络请求那章的时候需要服务器相应android应用发出的请求,书中使用的Apache服务器,但是呢,作为nodejs的粉丝,为什么不用nodejs呢,正好久闻KOA的大名,就准备拿来玩玩本文使用的第三方模块版本第一个应用!首先,使用npm安装koanp...

2017-09-17 16:01:46

阅读数:1588

评论数:0

手工搭建React+Webpack初级开发环境

起因想试试ReactJS,准备照着官网的教程学习一下,官网推荐的搭建本地开发环境是使用React自己的cli工具,但是呢,为了顺便再练习一下Webpack的使用 ,所以就手工搭建了目标 使用 webpack-merge 使开发(development)和 生产(production)分离 使用ba...

2017-08-29 23:09:01

阅读数:636

评论数:0

为MacOS升级vim至最新版

升级了一下本地的vim插件,YouCompleteMe报错: 最新版的ycm需要vim大于7.4.1578的版本,而Mac的默认版本较低,所以准备升级到最新的8.0+

2017-08-21 13:26:17

阅读数:2082

评论数:1

提示
确定要删除当前文章?
取消 删除
关闭
关闭