HDU 1114 Piggy-Bank 解题报告(完全背包)

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24128    Accepted Submission(s): 12216


Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 
 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
 

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". 
 

Sample Input
  
  
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4

Sample Output
  
  
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.
 

Source

Central Europe 1999



思路:动态规划,求出每个容量的最优解(一维数组dp存最优方案,结构体对象c的p存price价值,w存weight重量),将数组初始化为16843009,假设所有的现在还凑不出来,凑的出来,将所在位置的值改为凑出来的价值,最后判断输出结果

以这组数据为例:


1
1 13
3
3 2
2 3
4 4

由分析得出递归公式:dp[j] = min(dp[j],(dp[j - c[i].w])+  c[i].p); 


循环,推出最优解:


			memset(dp,0x1,sizeof(dp));//初始化为最大值
			dp[0] = 0;
			for(int i = 0;i < n;i++){//从第一个硬币开始循环
				for(int j = c[i].w;j <= f - e;j++){//循环开始的位置即重量的大小
						dp[j] = min(dp[j],(dp[j - c[i].w])+  c[i].p); //取最小
				}
			}
将测试用例代入图解:

共三种硬币(循环开始的坐标即该种硬币的重量)


      第一次循环 (只有第一种硬币时的最优解)





第二次循环(只有第一二种硬币时的最优解)





第三次循环(一二三种硬币时的最优解)



最后判断是佛有最优解即可


AC代码:


#include"iostream"
#include"algorithm"
using namespace std;
struct Coin{
	int p,w;

}c[500 + 5];
int dp[10000 + 5];
int main(){
	int t,f,e,n;
	while(~scanf("%d",&t)){
		for(int k = 0;k < t;k++){
			scanf("%d %d",&e,&f);
			scanf("%d",&n);
			for(int i = 0;i < n;i++)
				scanf("%d %d",&c[i].p,&c[i].w);

			memset(dp,0x1,sizeof(dp));//初始化为最大值
			dp[0] = 0;
			for(int i = 0;i < n;i++){//从第一个硬币开始循环
				for(int j = c[i].w;j <= f - e;j++){//循环开始的位置即重量的大小
						dp[j] = min(dp[j],(dp[j - c[i].w])+  c[i].p); //取最小
				}
			}
			if(dp[f - e] != dp[10004])
				printf("The minimum amount of money in the piggy-bank is %d.\n",dp[f - e]);
			else
				printf("This is impossible.\n");
		}
	}
	return 0;
}




  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值