1028 人口普查(20)(20 分)

1028 人口普查(20)(20 分)

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过200岁的老人,而今天是2014年9月6日,所以超过200岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:

输入在第一行给出正整数N,取值在(0, 10^5^];随后N行,每行给出1个人的姓名(由不超过5个英文字母组成的字符串)、以及按“yyyy/mm/dd”(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:

在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:

5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20

输出样例:

3 Tom John

思路:经过计算我们可以得知 范围 [1814.09.06 , 2014.09.06]范围内是合法的 那么就可以根据这个写出。

可能是我想多了 因为我还考虑到输入非法的情况 。题目里面的测试样例其实是不全的 因为它没有讲到 不会输入 诸如 2.30这样的数据 所以理应要额外判断 但是去除这样的判断其实答案也是正确的说明了 出题的人不严谨。

话不多说我们上代码:

#include <bits/stdc++.h>

using namespace std;


struct sn {
	string name;
	int year;
	int mouth;
	int day;
};

struct sn BZ[2] = { {"0",1814,9,6},{"1",2014,9,6} };
struct sn P[100000 + 10];

int cmp(struct sn ONE, struct sn TWO) {

	int flag = -1;
	if (ONE.year < TWO.year)
		return 0;
	else if (ONE.year == TWO.year)
		flag = 1;
	if (flag == 1 && ONE.mouth < TWO.mouth)
		return 0;
	else if (flag == 1 && ONE.mouth == TWO.mouth)
		flag = 2;
	if (flag == 2 && ONE.day < TWO.day)
		return 0;
	return 1;
}

bool CX(struct sn AT) {

	int dyear = -1;
	if (AT.year % 400 == 0 || (AT.year % 4 == 0 && AT.year % 100))
		dyear = 1;  // 闰年
	else dyear = 0; // 

	if (AT.mouth != 2) {
		if (AT.mouth == 1 || AT.mouth == 3 && AT.mouth == 5 && AT.mouth == 7 && AT.mouth == 8 && AT.mouth == 10 && AT.mouth == 12)
			return AT.day < 1 || AT.day>31 ? false : true;
		else
			return AT.day < 1 || AT.day>30 ? false : true;
	}
	return dyear ? AT.day < 1 || AT.day>29 ? false : true : AT.day < 1 || AT.day>28 ? false : true;
}

bool Boot(struct sn T_A) {

	int flag = -1;
	if (T_A.year > BZ[1].year || T_A.year < BZ[0].year)
		return false;
	if ((T_A.year == 2014 && T_A.mouth > 9) || (T_A.year == 1814 && T_A.mouth < 9))
		return false;
	if ((T_A.year == 2014 && T_A.mouth == 9 && T_A.day > 6) || (T_A.year == 1814 && T_A.mouth == 9 && T_A.day < 6))
		return false;

	return CX(T_A); // 改为 true 不用那个函数也算对!!!
}

void solve() {

	int x;
	int Pt = 0;
	scanf("%d", &x);
	for (int i = x; i--;) {
		struct sn TMP;
		TMP.name.resize(6);
		scanf("%s %d/%d/%d", &TMP.name[0], &TMP.year, &TMP.mouth, &TMP.day);
		if (Boot(TMP)) {
			P[Pt] = TMP;
			P[Pt++].name = TMP.name.data(); // 多余了
		}
	}
	sort(P, P + Pt, cmp);
	if(Pt)
	  printf("%d %s %s", Pt,P[Pt - 1].name.c_str(),P[0].name.c_str());
	else
	  printf("0");
}

int main() {

	solve();
	system("pause");
	return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值