1HDOJ 1089 ACM入门第一题,2简要介绍EOF,3多组数据输入

1ACM入门第一题,2简要介绍EOF,3多组数据输入

A+B for Input-Output Practice (I)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 97460    Accepted Submission(s): 53980


Problem Description
Your task is to Calculate a + b.
Too easy?! Of course! I specially designed the problem for acm beginners. 
You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim. 
 

Input
The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line. 
 

Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input. 
 

Sample Input
  
  
1 5 10 20
 

Sample Output
  
  
6 30
 

Author
lcy
 


/*******HDOJ 1089**************************** 

* 1EOF(end of file):
* 在linux下是ctrl+D,在windows下是ctrl+Z
* EOF定义在头文件<stdio.h>  #define EOF (-1)
* 2.scanf()函数返回的值为:
* 正确按指定格式输入变量的个数;
* 也即能正确接收到值的变量个数。
* 3
* 因为正确读入,所以scanf返回值为2!=EOF因此可用此方法实现多组数据输入
*/
#include <stdio.h>


int main()
{
    int a, b;
    while(~scanf("%d%d",&a, &b)) // while(EOF!=scanf("%d%d",&a, &b))
    {
        printf("%d\n",a+b);
    }
    return 0;
}
/*
input
1 5
10 20
正确打印是这样的格式(与样例输出有些不同)
print
1 5
6
10 20
30


*/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值