控制结构:3.被3,5,7整除

【问题描述】

输入一个整数,判断其能否被3、5、7整除,若:

(1)能同时被3,5,7整除,则输出It's divisible by 3,5,7;

(2)能被其中两数(要指出哪两个)整除(如能被3,7整除),则输出It's divisible by 3,7;

(3)能被其中一个数(要指出哪一个)整除(如能被3整除),则输出It's divisible by 3;

(4)不能被3,5,7任一个整除,则输出null。


【输入形式】

输入一个整数n。

【输出形式】

输出一个判断信息,表示答案。

【样例输入】

30

【样例输出】

It's divisible by 3,5

【样例说明】

30能被3和5整除,但是不能被7整除。

【用例规模与约定】

所有评测用例满足:-1000000 ≤ n ≤ 10000000。

#include<iostream>
using namespace std;
int main()
{
	int a;
	cin>>a;
	int j=2;
	for(int i=3;i<=7;i+=2)
	{
		if(a%i==0)
		{
		j*=i;	
		}
	}
	if(j==2)
	{
		cout<<"null"<<endl;
	}
	else if(j==6)
	{
		cout<<"It's divisible by 3"<<endl;
	}
	else if(j==10)
	{
		cout<<"It's divisible by 5"<<endl;
	}
	else if(j==14)
	{
		cout<<"It's divisible by 7"<<endl;
	}
	else if(j==30)
	{
		cout<<"It's divisible by 3,5"<<endl;
	}
	else if(j==42)
	{
		cout<<"It's divisible by 3,7"<<endl;
	}
	else if(j==70)
	{
		cout<<"It's divisible by 5,7"<<endl;
	}
	else if(j==210)
	{
		cout<<"It's divisible by 3,5,7"<<endl;
	}
	system("pause");
	return 0;
}
  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

一二爱上蜜桃猫

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值