POJ 3254 Corn Fields (状态压缩DP)

Corn Fields
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16130 Accepted: 8514

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

题意:农民有M*N的土地,1代表可以种玉米,0表示不能种,农民要放牛在种玉米地上吃谷物,然而牛不能放在相邻的位置上,问有几种放法。

方法利用状态压缩:row[]代表有空地的地方

                                   state[]表示可行的状态

                                  dp[i][j]在i行j的状态下的方法数。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define mod 100000000
int row[30];
int state[1000];
int dp[30][1000];
int m, n, cnt;
bool judge1(int x)//判断1不连续的情况
{
    if(x & x << 1)
        return false;
    return true;
}

bool judge2(int x, int y)//判断有空位的情况
{
    if(x & row[y])return false;
    return true;
}
void init()
{
    cnt=0;
    for(int i=0;i < (1<<n);i++)
    {
        if(judge1(i))
            state[cnt++] = i;
    }
    memset(row, 0, sizeof(row));
    memset(dp, 0, sizeof(dp));
}

int main()
{
    while(~scanf("%d%d", &m, &n))
    {
        init();
        int i, j, k, temp;
        for(i=1;i<=m;i++)
            for(j=1;j<=n;j++)
        {
            scanf("%d",&temp);
            if(temp == 0)
            {
                row[i] += 1 <<(n-j);
            }
        }
        for(i=0;i<cnt;i++)
        {
            if(judge2(state[i],1))
                dp[1][i]=1;
        }

        for(i=2;i<=m;i++)
        {
            for(j=0;j<cnt;j++){
                if(!judge2(state[j], i))continue;
                for(k=0;k<cnt;k++)
                {
                    if(!judge2(state[k], i-1))continue;
                    if(state[j] & state[k])continue;
                    dp[i][j] = (dp[i][j] + dp[i-1][k]) % mod;
                }
            }
        }

        int ans=0;
        for(i=0;i<cnt;i++)
            ans = (ans+dp[m][i]) % mod;
        printf("%d\n",ans+1);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值