数位dp-HDU3652

A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.
Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).
Output
Print each answer in a single line.
Sample Input
13
100
200
1000
Sample Output
1
1
2
2

             题目:在一个数的范围里找一种能被13整除且数字中含有13的数

             dp[]i[j]k[],i是数字位数, j是模13的余数,k是状态的

    

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int a[20];
int dp[20][20][3];//状态0:前一位不为1,状态1:前一位为1,状态2:前一位为1当前位为3

int dfs(int pos, int mod, int sta, bool limit)
{
    if(pos==0)
        return (mod==0&&sta==2);
    if(!limit && dp[pos][mod][sta]!= -1)
        return dp[pos][mod][sta];
    int up = limit ? a[pos]:9;
    int temp=0;
    for(int i=0;i<=up;i++)
    {
        int newmod = (mod*10 + i)%13;
        int cc = sta;
        if(sta==0 && i==1)cc=1;
        if(sta==1 && i!=1)cc=0;
        if(sta==1 && i==3)cc=2;
        temp += dfs(pos-1,newmod, cc, limit && i==up);
       // printf("%d\n", temp);
    }

    if(!limit)
        dp[pos][mod][sta] = temp;
    return temp;
}

int solve(int x)
{
    int len = 0;
    while(x)
    {
        a[++len] =  x%10;
        x/=10;
    }
    return dfs(len, 0, 0, true);
}

int main()
{
    int n;
    memset(dp, -1, sizeof(dp));
    while(~scanf("%d",&n))
    {
        printf("%d\n", solve(n));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值