Fibonacci Again

Fibonacci Again

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 49 Accepted Submission(s) : 19
Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output
Print the word “yes” if 3 divide evenly into F(n). Print the word “no” if not.

Sample Input

0
1
2
3
4
5

Sample Output

no
no
yes
no
no
no

计算过程如下:
斐波那契数列是一项的值等于前两项之和,因此可以很容易的写出计算这个数列值的代码,本道题里斐波那契数列第一二项为7和11,所以先观察数列规律,用3取余为零的规律。
计算本题中斐波那契数列的n项是否为3的倍数的代码如下(本代码不适用与题目):

#include <stdio.h>
int main()
{
    int a[100], i, n = 0;
    while (scanf("%d",&n)!=EOF)
    {
        a[1] = 11, a[0] = 7;
        for (i = 2; i < 100; i++)
            a[i] = a[i - 2] + a[i - 1];
        if (a[n] % 3 != 0)
            printf("no\n");
        else
            printf("yes\n");
    }
    return 0;
}

用程序算出来的之后发现2,6,10,14每四次出现一个符合的项
因此也就是输入的n%4=2的话这个项便是题目符合项,所以按规律算的话最后的代码还是很简单的:

#include <stdio.h>
int main()
{
    int n = 0;
    while (scanf("%d",&n)!=EOF)
    {
        if (n % 4 != 2)
            printf("no\n");
        else
            printf("yes\n");
    }
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值