【PAT】【Advanced Level】1103. Integer Factorization (30)

11 篇文章 0 订阅
5 篇文章 0 订阅

1103. Integer Factorization (30)

时间限制
1200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n1^P + ... nK^P

where ni (i=1, ... K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 + 12, or 112 + 62 + 22 + 22 + 22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1, a2, ... aK } is said to be larger than { b1, b2, ... bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL

If there is no solution, simple output "Impossible".

Sample Input 1:
169 5 2
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:
169 167 3
Sample Output 2:
Impossible
原题链接:
https://www.patest.cn/contests/pat-a-practise/1103

思路:

DFS+回溯+剪枝

DFS搜索因子

剪枝:

最大层数为K

保证搜索序列的是増序序列。

CODE:

#include<iostream>
#include<cmath>
#include<vector>
#include<cstdio>
#include<algorithm>
#define N 410
using namespace std;
typedef struct S
{
	int sum;
	int num[N];	
};
vector<S> res;
vector<int>  pa;
int nn,kk,pp;
void dfs(int n,int k, int p,int f)
{	
	if (k!=1)
	{
		for (int i=f;pow(i,p)<=n/k;i++)
		{
			int temp=(pow(i,p)+0.5);
			pa.push_back(i);
			dfs(n-temp,k-1,p,i);
			pa.erase(pa.end()-1);
		}
	}
	else
	{
		int t=-1;
		for (int i=1;pow(i,p)<=n;i++)
		{
			int pp=(pow(i,p)+0.5);
			if (pp==n)
			{
				t=i;
				break;
			}
		}
		if (t==-1) return ;
		pa.push_back(t);
		S ne;
		ne.sum=0;
		for(int i=0;i<pa.size();i++)
		{
			ne.sum+=pa[i];
			ne.num[i]=pa[i];
		}
		res.push_back(ne);
		pa.erase(pa.end()-1);
	}
}
bool cmp(S a,S b)
{
	if (a.sum==b.sum)
	{
		for (int i=0;i<kk;i++)
		{
			return a.num[i]>b.num[i];
		}
	}
	else
	{
		return a.sum>b.sum;
	}
}
int main()
{
	scanf("%d %d %d",&nn,&kk,&pp);
	dfs(nn,kk,pp,1);
	if (res.size()==0)
	{
		printf("Impossible");
	}
	else
	{
		sort(res.begin(),res.end(),cmp);
		S pt=res[0];
		printf("%d = ",nn);
		for (int i=kk-1;i>=0;i--)
		{
			printf("%d^%d",pt.num[i],pp);
			if (i!=0) printf(" + ");
		}
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值