奶牛挤奶

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0…N-1) so that she produces as much milk as possible.
Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.
Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

  • Line 1: Three space-separated integers: N, M, and R
  • Lines 2…M+1: Line i+1 describes FJ’s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

  • Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

题意:给了N的时间(没什么用),m个时间段,每个时间段有开始时间,结束时间,挤奶量,每次挤完奶需要休息的时间r,求m个时间段里最大的挤奶量。

思路:开始给的时间段是无序的,需要先排一下序;设f[i]:到第i个时间段截止的最大挤奶量。有两种情况,挤奶,不挤奶,具体是挤还是不挤,就看两个时间段第1个的结束时间加上r是不是比第2个时间段的开始时间小。那么就枚举每一个时间段,计算到第i个时间段里的最大挤奶量。

状态转移方程:f[i] = max(f[i],f[j]+a[i].val)

代码

#include <iostream>
#include <algorithm>
using namespace std;
const int N = 1010;
struct node
{
 int start;
 int end;
 int val;
};
bool cmp(node a, node b)
{
 if(a.start != b.start)
  return a.start < b.start;
 else
  return a.end < b.end;
}
node a[N];
int f[N];
int n,m,r;
int main()
{
 cin >> n >> m >> r;
 for(int i = 1; i <= m; i++)
  cin >> a[i].start >> a[i].end >> a[i].val;
 sort(a+1,a+m+1,cmp);//当时m写成了n算了半天结果都是0
 int maxx = -99999;
 for(int i = 1; i <= m; i++)
 {
  f[i] = a[i].val;//每个时间段都有自己相应的挤奶量
  //cout << f[i] << " ";
  for(int j = 1; j <= i; j++)
  {
   if(a[j].end + r <= a[i].start)//如果能挤
    f[i] = max(f[i],f[j]+a[i].val);
  }
  //cout << f[i] << " ";
  maxx = max(maxx,f[i]);//最后一次挤奶不一定是最后一个时间段
 }
 cout << maxx << endl;
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值