POJ 1071Illusive Chase(DFS)

Illusive Chase
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 1003 Accepted: 455

Description

Tom the robocat is presented in a Robotics Exhibition for an enthusiastic audience of youngsters, placed around an m * n field. Tom which is turned off initially is placed in some arbitrary point in the field by a volunteer from the audience. At time zero of the show, Tom is turned on by a remote control. Poor Tom is shown a holographic illusion of Jerry in a short distance such that a direct path between them is either vertical or horizontal. There may be obstacles in the field, but the illusion is always placed such that in the direct path between Tom and the illusion, there would be no obstacles. Tom tries to reach Jerry, but as soon as he gets there, the illusion changes its place and the chase goes on. Let's call each chase in one direction (up, down, left, and right), a chase trip. Each trip starts from where the last illusion was deemed and ends where the next illusion is deemed out. After a number of chase trips, the holographic illusion no more shows up, and poor Tom wonders what to do next. At this time, he is signaled that for sure, if he returns to where he started the chase, a real Jerry is sleeping and he can catch it. 

To simplify the problem, we can consider the field as a grid of squares. Some of the squares are occupied with obstacles. At any instant, Tom is in some unoccupied square of the grid and so is Jerry, such that the direct path between them is either horizontal or vertical. It's assumed that each time Tom is shown an illusion; he can reach it by moving only in one of the four directions, without bumping into an obstacle. Tom moves into an adjacent square of the grid by taking one and only one step. 

The problem is that Tom's logging mechanism is a bit fuzzy, thus the number of steps he has taken in each chase trip is logged as an interval of integers, e.g. 2 to 5 steps to the left. Now is your turn to send a program to Tom's memory to help him go back. But to ease your task in this contest, your program should only count all possible places that he might have started the chase from. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains two integers m and n, which are the number of rows and columns of the grid respectively (1 <= m, n <= 100). Next, there are m lines, each containing n integers which are either 0 or 1, indicating whether the corresponding cell of the grid is empty (0) or occupied by an obstacle (1). After description of the field, there is a sequence of lines, each corresponding to a chase trip of Tom (in order). Each line contains two positive integers which together specify the range of steps Tom has taken (inclusive), followed by a single upper-case character indicating the direction of the chase trip, which is one of the four cases of R (for right), L (for left), U (for up), and D (for down). (Note that these directions are relative to the field and are not directions to which Tom turns). This part of the test case is terminated by a line containing exactly two zeros.

Output

For each test case, there should be a single line, containing an integer indicating the number of cells that Tom might have started the chase from.

Sample Input

2
6 6
0 0 0 0 0 0
0 0 0 1 1 0
0 1 0 0 0 0
0 0 0 1 0 0
0 0 0 1 0 1
0 0 0 0 0 1
1 2 R
1 2 D
1 1 R
0 0
3 4
0 0 0 0
0 0 0 0
0 0 0 0
1 2 R
3 7 U
0 0

Sample Output

10
0


题目大意:先给你一幅图,0表示可以走,1表示障碍物。在第1s的时候,向R(右)走1~2步,第2s的时候,向D(下)方向走1~2步,第3s的时候向右走一步。问有多少个起始点满足要求。

   题目地址:Illusive Chase

    DFS。

AC代码:
#include<iostream>
#include<cstdio>
using namespace std;
int m,n,p;
int mp[105][105];
int dir[4][2]={{-1,0},{0,1},{1,0},{0,-1}};

struct node
{
    int a;
    int b;
    int val;
}nod[10005];

int dfs(int x,int y,int step)
{
    if(step==p) return 1;
    int a=nod[step].a;
    int b=nod[step].b;
    int dd=nod[step].val;
    int cx,cy;
    for(int i=1;i<a;i++)
    {
        cx=x+dir[dd][0]*i,cy=y+dir[dd][1]*i;
        if(mp[cx][cy]) return 0;
        if(cx<0||cx>=m||cy<0||cy>=n) return 0;
    }

    for(int i=a;i<=b;i++)
    {
        cx=x+dir[dd][0]*i,cy=y+dir[dd][1]*i;
        if(cx<0||cx>=m||cy<0||cy>=n) break;
        if(mp[cx][cy]) break;
        if(dfs(cx,cy,step+1)) return 1;
    }
    return 0;
}

int main()
{
    int tes,i,j;
    int a,b,val;
    char c;
    cin>>tes;
    while(tes--)
    {
        cin>>m>>n;
        p=0;
        for(i=0;i<m;i++)
            for(j=0;j<n;j++)
                scanf("%d",&mp[i][j]);

        while(scanf("%d%d",&a,&b))
        {
            if(a==0&&b==0) break;
            scanf(" %c",&c);
            if(c=='U') val=0;
            else if(c=='R') val=1;
            else if(c=='D') val=2;
            else val=3;
            nod[p].a=a,nod[p].b=b,nod[p++].val=val;
        }

        int res=0;
        for(i=0;i<m;i++)
            for(j=0;j<n;j++)
                if(mp[i][j]==0)
                    res+=dfs(i,j,0);
        cout<<res<<endl;
    }
    return 0;
}

/*
2
6 6
0 0 0 0 0 0
0 0 0 1 1 0
0 1 0 0 0 0
0 0 0 1 0 0
0 0 0 1 0 1
0 0 0 0 0 1
1 2 R
1 2 D
1 1 R
0 0
3 4
0 0 0 0
0 0 0 0
0 0 0 0
1 2 R
3 7 U
0 0
*/



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值