hdu 1364 - Illusive Chase【dfs】

SDNU_ACM_ICPC_2020_Winter_Practice_3rd A - lzwの玩耍
hdu 1364 - Illusive Chase
参考题解

Tom the robocat is presented in a Robotics Exhibition for an enthusiastic audience of youngsters, placed around an m n field. Tom which is turned off initially is placed in some arbitrary point in the field by a volunteer from the audience. At time zero of the show, Tom is turned on by a remote control. Poor Tom is shown a holographic illusion of Jerry in a short distance such that a direct path between them is either vertical or horizontal. There may be obstacles in the field, but the illusion is always placed such that in the direct path between Tom and the illusion, there would be no obstacles. Tom tries to reach Jerry, but as soon as he gets there, the illusion changes its place and the chase goes on. Let’s call each chase in one direction (up, down, left, and right), a chase trip. Each trip starts from where the last illusion was deemed and ends where the next illusion is deemed out. After a number of chase trips, the holographic illusion no more shows up, and poor Tom wonders what to do next. At this time, he is signaled that for sure, if he returns to where he started the chase, a real Jerry is sleeping and he can catch it.
To simplify the problem, we can consider the field as a grid of squares. Some of the squares are occupied with obstacles. At any instant, Tom is in some unoccupied square of the grid and so is Jerry, such that the direct path between them is either horizontal or vertical. It’s assumed that each time Tom is shown an illusion; he can reach it by moving only in one of the four directions, without bumping into an obstacle. Tom moves into an adjacent square of the grid by taking one and only one step.
The problem is that Tom’s logging mechanism is a bit fuzzy, thus the number of steps he has taken in each chase trip is logged as an interval of integers, e.g. 2 to 5 steps to the left. Now is your turn to send a program to Tom’s memory to help him go back. But to ease your task in this contest, your program should only count all possible places that he might have started the chase from.

Input
The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains two integers m and n, which are the number of rows and columns of the grid respectively (1 <= m, n <= 100). Next, there are m lines, each containing n integers which are either 0 or 1, indicating whether the corresponding cell of the grid is empty (0) or occupied by an obstacle (1). After description of the field, there is a sequence of lines, each corresponding to a chase trip of Tom (in order). Each line contains two positive integers which together specify the range of steps Tom has taken (inclusive), followed by a single upper-case character indicating the direction of the chase trip, which is one of the four cases of R (for right), L (for left), U (for up), and D (for down). (Note that these directions are relative to the field and are not directions to which Tom turns). This part of the test case is terminated by a line containing exactly two zeros.

Output
For each test case, there should be a single line, containing an integer indicating the number of cells that Tom might have started the chase from.

Sample Input
2
6 6
0 0 0 0 0 0
0 0 0 1 1 0
0 1 0 0 0 0
0 0 0 1 0 0
0 0 0 1 0 1
0 0 0 0 0 1
1 2 R
1 2 D
1 1 R
0 0
3 4
0 0 0 0
0 0 0 0
0 0 0 0
1 2 R
3 7 U
0 0

Sample Output
10
0

【题意】
Tom在网格上抓Jerry,
有t(1<=t<=10)组样例,
给出m*n(1<=m,n<=100)的网格,障碍0无1有,
给出Tom每步所走格数的最小值、最大值、方向,以0 0结束,
要求出发点和过程中均无障碍,
且走完所有步仍未越界,
求Tom可能出发的地点数。

【思路】
用结构体w存放每步所走格数的最小值、最大值、方向,
用两个数组dy、dx改变方向,

方向
num0123
w[num].dirLRDU
dy[num]001-1
dx[num]-1100

从左上角开始,dfs每一个点,
详见注释。(每走一步可以往该方向拱好几格,把Tom想象成一个小卒子在棋盘上拱啊拱。。

#include<bits/stdc++.h>
using namespace std;
//A - lzwの玩耍 & hdu 1364 - Illusive Chase
int mp[110][110], t, m, n, num, cnt;
int dy[4] = {0, 0, 1, -1}, dx[4] = {-1, 1, 0, 0};
struct wwr
{
    int l, r, dir;
}w[10000];//这里有点莫名其妙,好像题目没说给定几步,往大的开竟然可以过嘿嘿。。

bool dfs(int y, int x, int ge, int step)//ge:该步中已经拱了几格
{
    if(step == num)//判断是否走完所有步
        return 1;//返回上一步
    if(ge >= w[step].l && ge <= w[step].r)//判断已拱格数是否在该步最小最大范围内。若是则再走一步,进入下一次dfs,判断此后是否可行
        if(dfs(y, x, 0, step + 1))
            return 1;//返回上一步
    if(ge < w[step].r)//判断已拱格数是否小于该步的最大范围。若是则再往该步的方向上拱一格,判断是否越界。若没越界则已拱格数+1,进入下一次dfs,判断此后是否可行
    {
        int ny = y + dy[w[step].dir], nx = x + dx[w[step].dir];
        if(ny >= 0 && ny < m && nx >= 0 && nx < n && mp[ny][nx] == 0)
            if(dfs(ny, nx, ge + 1, step))
                return 1;//返回上一格
    }
    return 0;
}

int main()
{
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d %d", &m, &n);
        for(int i = 0; i < m; i++)
            for(int j = 0; j < n; j++)
                scanf("%d", &mp[i][j]);
        num = 0;
        while(~scanf("%d %d", &w[num].l, &w[num].r) && (w[num].l || w[num].r))
        {
            char c;
            cin>>c;
            if(c == 'L')
                w[num].dir = 0;
            else if(c == 'R')
                w[num].dir = 1;
            else if(c == 'D')
                w[num].dir = 2;
            else if(c == 'U')
                w[num].dir = 3;
            num++;
        }
        cnt = 0;
        for(int i = 0; i < m; i++)//开始遍历每一个点
            for(int j = 0; j < n; j++)
                if(mp[i][j] == 0 && dfs(i, j, 0, 0))
                    cnt++;//可行点数+1
        printf("%d\n", cnt);
    }
    return 0;
}

啊啊啊第一次写博客!!!好鸡冻!!!

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值