hdu 3177Crixalis's Equipment(贪心)

Crixalis's Equipment

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2286    Accepted Submission(s): 924


Problem Description
Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts of Kalimdor. Though he's a guardian of Lich King now, he keeps the living habit of a scorpion like living underground and digging holes.

Someday Crixalis decides to move to another nice place and build a new house for himself (Actually it's just a new hole). As he collected a lot of equipment, he needs to dig a hole beside his new house to store them. This hole has a volume of V units, and Crixalis has N equipment, each of them needs Ai units of space. When dragging his equipment into the hole, Crixalis finds that he needs more space to ensure everything is placed well. Actually, the ith equipment needs Bi units of space during the moving. More precisely Crixalis can not move equipment into the hole unless there are Bi units of space left. After it moved in, the volume of the hole will decrease by Ai. Crixalis wonders if he can move all his equipment into the new hole and he turns to you for help.
 

Input
The first line contains an integer T, indicating the number of test cases. Then follows T cases, each one contains N + 1 lines. The first line contains 2 integers: V, volume of a hole and N, number of equipment respectively. The next N lines contain N pairs of integers: Ai and Bi.
0<T<= 10, 0<V<10000, 0<N<1000, 0 <Ai< V, Ai <= Bi < 1000.
 

Output
For each case output "Yes" if Crixalis can move all his equipment into the new hole or else output "No".
 

Sample Input
  
  
2 20 3 10 20 3 10 1 7 10 2 1 10 2 11
 

Sample Output
  
  
Yes No
 

题目大意:开始有能量V,然后有n个障碍物,打败第i个障碍物,需要bi的能量(V>=bi),打败之后能量会减少ai(V=V-ai)。问你有没有可能选择一种顺序方式,使得可以将所有障碍物都打败,可以的话输出yes,else输出no.

        解题思路:开始是分了两个数组讨论,按照bi排一遍,再按照ai排一遍,试了很多方法,一直WA,没有想到利用策略来找关系。

假设有第i个障碍物与第j个障碍物。
如果先放i后放j那么有
V>=bi,V>=ai+bj;
如果先放j后放i那么有
        V>=bj,V>=aj+bi;

对上面的再分析,如果先放i后放j,那么V>=bi,V>=ai+bj;并且下面的的式子不成立,但是V>=bj成立,所以有aj+bi>V
那么可以得到aj+bi>ai+bj;即为bi-ai>bj-aj;
按照这个排序,然后依次处理即可。
详见代码。

题目地址:Crixalis's Equipment

AC代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
using namespace std;

struct nod
{
    int a;
    int b;
};
nod node[1005];

int cmp(nod p1,nod p2)
{
    if(p1.b-p1.a>=p2.b-p2.a) return 1;
    return 0;
}

int main()
{
    int tes;
    cin>>tes;

    int v,n,i;
    while(tes--)
    {
        cin>>v>>n;
        for(i=0;i<n;i++)
            cin>>node[i].a>>node[i].b;

        sort(node,node+n,cmp);

        int flag=0;
        for(i=0;i<n;i++)
        {
            if(node[i].b>v)
            {
                flag=1;
                break;
            }
            else
            {
                v-=node[i].a;
            }
        }

        if(flag==1) puts("No");
        else puts("Yes");
    }
    return 0;
}

/*
34
10 2
9 9
1 5

10 2
3 10
1 5

20 3
10 20
3 10
1 7

10 2
1 10
2 11

8 3
6 7
1 2
1 1

8 3
6 8
1 1
1 2
*/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值