POJ 2411Mondriaan's Dream(类似hdu1992铺砖问题)

Mondriaan's Dream
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 10591 Accepted: 6163

Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways. 

Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205


题目大意:和上个题目差不多,http://acm.hdu.edu.cn/showproblem.php?pid=1992。不过这个框框的大小是变化的。

解题思路:和上一个一样,状压dp,用0表示不占用下一行的,1表示占用下一行的情况。不过需要枚举列。然后找状态转移即可。会爆int32需要用long long..



AC代码:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;

long long dp[15][15][2050];

void dfs(int r,int c,int cur,int nex,int m)
{
    if(c>=m)
    {
        dp[r+1][m][nex]+=dp[r][m][cur];
        return;
    }
    if(!(cur&(1<<c)))
    {
        dfs(r,c+1,cur,nex|(1<<c),m);   //可以放一个1
        if(c<=m-2&&(!(cur&(1<<(c+1)))))  //可以放00
            dfs(r,c+2,cur,nex,m);
    }
    else
        dfs(r,c+1,cur,nex,m);
}

int main()
{
    int i,j,k;
    memset(dp,0,sizeof(dp));
    for(i=0;i<15;i++)
        dp[0][i][0]=1;   //把框框的列数确定找每一行的

    for(i=1;i<12;i++)  //确定列数
    {
        int tmp=1<<i;
        for(j=0;j<12;j++)   //确定每一行
        {
            for(k=0;k<tmp;k++)
                if(dp[j][i][k])
                    dfs(j,0,k,0,i);
        }
    }

    int n,m;
    while(cin>>n>>m)
    {
        if(n+m==0) break;
        cout<<dp[n][m][0]<<endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值