[POJ][1004]Financial Management

Description

Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

Input

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

Output

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.

Sample Input

100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75

Sample Output

$1581.42
 

这也是传说中的一道水题,题目要求输出12个数的平均值,要求四舍五入,保留两位小数,这里涉及到输出格式的控制,可以使用setiosflags(ios::fixed)和setprecision(2),这样输出结果会使用小数形式且保留最后两位小数,注意这里其实是自动四舍五入到百分位,相当方便。数据使用float足够。

下面给出AC代码

#include<iostream>
#include<iomanip>
using namespace std;
int main()
{
    float c,num=0;
    while(cin>>c)
    {
        num+=c;
    }
    cout<<setiosflags(ios::fixed)<<setprecision(2)<<'$'<<num/12<<endl;
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值