HDU-1064-Financial Management(水题测试......真无双-大水果)

Financial Management

Time Limit: 400/200 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10333    Accepted Submission(s): 6400


Problem Description
Larry graduated this year and finally has a job. He’s making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what’s been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
 

Input
The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.
 

Output
The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.
 

Sample Input
  
  
100.00 489.12 12454.12 1234.10 823.05 109.20 5.27 1542.25 839.18 83.99 1295.01 1.75
 

Sample Output
  
  
$1581.42
 

Source
 

Recommend
PrincetonBoy   |   We have carefully selected several similar problems for you:   1076  1070  1056  1090  1062 

好久没来做题了,今天回家测试一下......来一个大大的水题!顺便好好翻译一下......(求平均数)

题目翻译:
劳瑞在今年毕业的最后得到了一个工作,赚了很多钱,但是无论怎么看都不够。(谁会觉得钱够?)劳瑞决定抓住他整体的财政并且解决他的经济问题。这个第一步就是弄清楚他的钱去哪里了。劳瑞有他自己的银行账户,并且想要看他自己有多少钱。通过写一个程序获取他过去每12个月的经济,并计算他们的平均值。

输入:
输入将有12行,每一行都是劳瑞每个月的银行经济值。每个数字都是精确的并且以便士的形式表现出来。并不是美元。

输出:
这个输出将只有一个数字,就是他12个月的平均经济,它将最接近分钱(就是保留两位小数)。是在美元注册之前。并且在最后一行没有空格或者其他字符!



#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    double a,sum=0;
    for(int i=0;i<12;i++)
    {
        scanf("%lf",&a);
        sum+=a;
    }
    printf("$%.2lf\n",sum/12);
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值