[POJ][1007]DNA Sorting

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA


这道题比较简单,但是代码里有个亮点,简化了代码。

读取输入,计算每个字符串的inversion,注意这里使用一个数组来存储他们的inversion,但是并非普通的存储,而是1000*inversion+index,这里其实是一个加权的值,inversion的权重远大于index的权重,可以保证在使用sort对这个数组进行排序时,inversion小的一定排在前面,而inversion相同的则按原顺序排列,这样一个数值里面既存了inversion也存了index,sort之后把让每个元素模1000就可以知道对应的字符串的序号,字符串存储完全按照原顺序。

下面给出AC代码

#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
    int n,m;
    cin>>n>>m;
    string* s=new string[m];
    int* p=new int[m];
    for(int i=0;i<m;++i)
    {
        cin>>s[i];
        int z=0;
        for(int j=0;j<n-1;++j) for(int k=j+1;k<n;++k) if(s[i][j]>s[i][k]) ++z;//计算inversion
        p[i]=1000*z+i;//存储的inversion还带有i,inversion权重远大于i
    }
    sort(p,p+m);
    for(int i=0;i<m;++i) cout<<s[p[i]%1000]<<endl;
    delete[] s;
    delete[] p;
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值