[POJ][1014]Dividing

Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000. 
The last line of the input file will be "0 0 0 0 0 0"; do not process this line.

Output

For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.". 
Output a blank line after each test case.

Sample Input

1 0 1 2 0 0 
1 0 0 0 1 1 
0 0 0 0 0 0 

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.

这道题其实可以直接DFS通过,0MS,和1011类似,但是比1011简单

就是就相当于看能不能组成一个价值为总价值一般的大理石集合,直接从价值最大的大理石开始搜索,搜得到就说明可以均分,搜不到就说不明不能均分,下面是AC代码

和1011不同的是我们这里没有回溯,也就是说检测到分配不合法的时候没有让大理石重新复原,因为没有必要.而且令我奇怪的是如果加上了回溯的那句代码反而会TLE

#include <iostream>
using namespace std;
int number[6]={0},sum=0;
bool find(int needvalue, int rightend)
{
	if(needvalue==0) return true;
	for(int i=rightend;i>=0;i--)
	{
		if(number[i]==0) continue;
        if((i+1)<=needvalue)
		{
			number[i]--;
			if(find(needvalue-i-1, i)) return true;
		}
        if (needvalue==sum) return false;
	}
	return false;
    
}

int main()
{
    int xuhao=1;
    for (int i=0; i<6; i++) {
        cin>>number[i];
        sum += number[i]*(i+1);
    }
	while(sum != 0)
	{
		if (sum%2) {
            cout<<"Collection #"<<xuhao++<<":"<<endl<<"Can't be divided."<<endl<<endl;
        } else {
            sum/=2;
            if(find(sum, 5)) {
                cout<<"Collection #"<<xuhao++<<":"<<endl<<"Can be divided."<<endl<<endl;
            } else {
                cout<<"Collection #"<<xuhao++<<":"<<endl<<"Can't be divided."<<endl<<endl;
            }
        }
        sum=0;
		for (int i=0; i<6; i++) {
            cin>>number[i];
            sum += number[i]*(i+1);
        }
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值