HDU - 1086 You can Solve a Geometry Problem too(坐标差乘)

Problem Description
Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :)
Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point.
Note
You can assume that two segments would not intersect at more than one point.
Input
Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending.
A test case starting with 0 terminates the input and this test case is not to be processed.
Output
For each case, print the number of intersections, and one line one case.
Sample Input
2
0.00 0.00 1.00 1.00
0.00 1.00 1.00 0.00
3
0.00 0.00 1.00 1.00
0.00 1.00 1.00 0.000
0.00 0.00 1.00 0.00
0

Sample Output
1
3

Author
lcy

Recommend
We have carefully selected several similar problems for you: 1115 1392 2108 2036 2150

#include <iostream>
#include <cstdio>
using namespace std;
typedef struct Stu
{
    double x;
    double y;
}stu;

int N;

int chacheng(stu c,stu c1,stu c2)
{
/*  int d_x1 = (c1.x - c.x);
    int d_y1 = (c1.y - c.y);
    int d_x2 = (c2.x - c.x);
    int d_y2 = (c2.y - c.y);
    ans = d_x1*d_y2-d_y1*d_y2*/
    double ans = (c1.x - c.x)*(c2.y - c.y)-(c1.y - c.y)*(c2.x - c.x);
    return ans;
}
bool panduan(stu c,stu c1,stu c2,stu c3)
{
    double d1,d2,d3,d4;
     d1 = chacheng(c,c1,c2);
     d2 = chacheng(c,c1,c3);
     d3 = chacheng(c2,c3,c);
     d4 = chacheng(c2,c3,c1);
//   if(((d1*d2>) || (d3*d4>=0)) return false;
//   else return true;
//   cout <<"d1="<<d1<<" d2="<<d2<<" d3="<<d3<<" d4="<<d4<<endl;
     if((d1*d2<0 && d3*d4<0) || (d1*d2==0 && d3*d4==0)/*如果d1*d2==0 && d3*d4==0原本会出现两种情况
        (1.两直线重合(2.两直线一个端点重合,介于本题输入的要求无重合情况,所以可以这样写*/)
     {

        return true;
     }
     else return false;
}
int main()
{
    stu a[105],b[105];
    while(scanf("%d",&N) && N)
    {
        int anss = 0;
        for(int i=1;i<=N;i++)
        {
            scanf("%lf%lf%lf%lf",&a[i].x,&a[i].y,&b[i].x,&b[i].y);
        }
        for(int i=1;i<N;i++){
            for(int j=i+1;j<=N;j++){
                bool k = panduan(a[i],b[i],a[j],b[j]);

                if(k){
                    anss++;
                }

            }
        }
        printf("%d\n",anss);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值