这道题 怪我没有好好地去审题。结果问题出在输出NO 和 N 上 无语死了。啊~我死了 (死得好?~)
1012 数字分类 (20)(20 分)
给定一系列正整数,请按要求对数字进行分类,并输出以下5个数字:
A1 = 能被5整除的数字中所有偶数的和;
A2 = 将被5除后余1的数字按给出顺序进行交错求和,即计算n1-n2+n3-n4...;
A3 = 被5除后余2的数字的个数;
A4 = 被5除后余3的数字的平均数,精确到小数点后1位;
A5 = 被5除后余4的数字中最大数字。
输入格式:
每个输入包含1个测试用例。每个测试用例先给出一个不超过1000的正整数N,随后给出N个不超过1000的待分类的正整数。数字间以空格分隔。
输出格式:
对给定的N个正整数,按题目要求计算A1~A5并在一行中顺序输出。数字间以空格分隔,但行末不得有多余空格。
若其中某一类数字不存在,则在相应位置输出“N”。
输入样例1:
13 1 2 3 4 5 6 7 8 9 10 20 16 18
输出样例1:
30 11 2 9.7 9
输入样例2:
8 1 2 4 5 6 7 9 16
输出样例2:
N 11 2 N 9
没什么好说的 题目说的贼明白,定义各种方法变量 来存这存那,最后在判断输出就好,看到题目里面说的正整数了吗?没错 0就是非法值。(刚刚想了一下== 我学C 之前没有学过任何编程,我也不知道为什么我会非常愿意在这上面花时间,因为爱吧。)
AC的代码:
#include <bits/stdc++.h>
using namespace std;
int cmp(int x, int y) {
return x > y?1:0;
}
void solve() {
int x;
scanf("%d",&x);
vector<int>A;
int no_10 = 0;
vector<int>B;
int ftcnt = 0;
vector<int>C;
int pd = 0;
double favg = 0;
int gs = 0;
for (int i = x,sc; i--;) {
scanf("%d",&sc);
A.push_back(sc);
if (sc % 5 == 0 && sc % 2 == 0) // 被5整除 且 是偶数
no_10 += sc,pd = 1; // pd == 1 说明有加过
else if (sc % 5 == 1) // B不为空说明 存在
B.push_back(sc);
else if(sc % 5 == 2) // ftcnt 为 0 说明不存在
ftcnt++;
else if (sc % 5 == 3)
favg += sc,gs++;
else if (sc % 5 == 4)
C.push_back(sc); // C为空 不存在
}
if (no_10)
printf("%d ", no_10);
else
printf("N ");
if (B.empty())
printf("N ");
else {
int x = 1;
int dsum = 0;
for (int i = 0; i < B.size(); i++)
if (x == 1)
dsum += B[i], x = 2;
else if (x == 2)
dsum -= B[i], x = 1;
printf("%d ", dsum);
}
if (!ftcnt)
printf("N ");
else
printf("%d ", ftcnt);
if (!gs)
printf("N ");
else
printf("%.1lf ", favg/gs);
if (C.empty())
printf("N");
else {
sort(C.begin(), C.end(), cmp);
printf("%d",C[0]);
}
}
int main() {
solve();
return 0;
}