UVAlive 3026 Period [KMP]

Period
Time Limit: 3000MS
64bit IO Format: %lld & %llu

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and
126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 ≤ i ≤ N)
we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be
written as AK, that is A concatenated K times, for some string A. Of course, we also want to know
the period K.

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains
N (2 ≤ N ≤ 1000000) the size of the string S. The second line contains the string S. The input file
ends with a line, having the number zero on it.

Output
For each test case, output ‘Test case #’ and the consecutive test case number on a single line; then, for
each prefix with length i that has a period K > 1, output the prefix size i and the period K separated
by a single space; the prefix sizes must be in increasing order.

Print a blank line after each test case.

Sample Input
3
aaa
12
aabaabaabaab
0

Sample Output
Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4


通过fail数组找循环节
错位部分为 i - fail(i) , 那么当 k * ( i - fail(i) ) == i 时, 找到循环
但是要注意判断要从1开始, 否则面临整数被0除!!
并且一直要循环到 lens 处 , 因为 get_fail 时是推到了 i+1 项的!!! 一定要注意!!!! 理解算法细节!!!

另外每组之间一行 ‘\n’

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<vector>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<string>
#include<iomanip>
#include<ctime>
#include<climits>
#include<cctype>
#include<algorithm>
#ifdef WIN32
#define AUTO "%I64d"
#else
#define AUTO "%lld"
#endif
using namespace std;
#define smax(x,tmp) x=max((x),(tmp))
#define smin(x,tmp) x=min((x),(tmp))
#define maxx(x1,x2,x3) max(max(x1,x2),x3)
#define minn(x1,x2,x3) min(min(x1,x2),x3)
const int INF=0x3f3f3f3f;
const int maxn = 1000005;
char s[maxn];
int lens;
int fail[maxn];
void get_fail(char s[],int lens)
{
    memset(fail,0,sizeof(fail));
    fail[0] = 0; fail[1] = 0;
    for(int i=1;i<lens;i++)
    {
        int root = fail[i];
        while(root && s[root]!=s[i]) root = fail[root];
        fail[i+1] = s[root]==s[i]? root+1 : 0;
    }
}
int main()
{
    freopen("period.in","r",stdin);
    freopen("period.out","w",stdout);
    int cas = 0;
    while(~scanf("%d",&lens) && lens)
    {
        scanf("%s",s);
        get_fail(s,lens);
        printf("Test case #%d\n",++cas);
        for(int i=1;i<=lens;i++) // from 1 or divided by 0
            if(i%(i-fail[i])==0)
            {
                int k = i / (i-fail[i]);
                if(k<=1) continue;
                printf("%d %d\n",i,k);
            }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值