Gradle入门指南(二)

版权声明:转载请注明出处: https://blog.csdn.net/ouyida3/article/details/46699101

转载请标明出处:
本文出自:【ouyida3的博客

注意:本文内容都是通过gradle命令行完成,不涉及eclipse的插件。

1、先阅读

Gradle入门指南(一)

2、常用命令

gradle -v
gradle build
gradle build --stacktrace
gradle publish
gradle -q publish
gradle clean
gradle complieJava

stacktrace会显示详细错误信息。不用记住,错误的时候会提示你这么–加到后面的

-q是不显示正常的信息,只显示错误的信息,建议还是不要用-q

publish是生成jar包发布到nexus

3、一些知识

我虽然是gradle结合nexus用,但是jar包在本机不再下载到maven,而是下载到gradle的目录:

C:\Documents and Settings\Administrator.gradle\caches\modules-2\files-2.1

4、一些错误解决

Could not resolve all dependencies for configuration ‘:compile’.

》 Could not find com.ai:ipaas-common:0.1-SNAPSHOT.

解决方法:gradle -q publish,必须先把snapshot的jar发布到nexus中(必须要有源代码)
http://www.iteye.com/topic/1134762
http://www.infoq.com/cn/news/2011/04/xxb-maven-6-gradle

publish后:
这里写图片描述

Execution failed for task ‘:compileJava’.

》 无效的源版本: 1.7

解决方法:Gradle使用path路径下的jdk,当然,你也可以设置JAVA_HOME指向你的jdk安装路径。
http://www.th7.cn/Program/java/201411/307185.shtml
修改java_home和path,指向1.7即可。注意:改后必须重启cmd。

You cannot upload a snapshot version into a release repository

nexus:
You cannot upload a snapshot version into a release repository

首先说名一下,这个是nexus的报错。是我上传一个snapshot的jar到release里报的。我觉得release里不能上传很合理,但是怎么办?网上都说使用maven,但是我没有源代码啊晕。
最后我把jar改名,把snapshot去掉上传上去,然后修改build.gradle把snapshot也去掉解决。

Could not resolve all dependencies for configuration ‘:compile’.

》 Could not find commons-codec.jar (commons-codec:commons-codec:1.6).

解决方法:因为nexus里没有这个jar。没有的原因是nexus的配置的仓库里确实没有,需要修改nexus仓库,增加镜像。然后用eclipse里pom就可以看到1.6,选中就自动下载。
但是gradle不知道怎么触发重新下载,下载后还是报错,删除.gradle\caches\modules-2\files-2.1和metadata-2.15下的1.6文件夹都不行,删除项目中的.gradle文件夹也不行。改名为commons-codec.jar不行,在build.gradle里增加compile “commons-codec:commons-codec:1.6”不行。
最后,我没有1.6的,使用了1.9版本解决(在build.gradle里增加compile “commons-codec:commons-codec:1.9”)。
其实,成功与不成功的关键在于C:\Documents and Settings\Administrator.gradle\caches\modules-2\files-2.1\commons-codec\commons-codec\1.6里是否有jar。

这里写图片描述

Could not resolve all dependencies for configuration ‘:compile’.

》 Could not find javax.mail:javax.mail:1.4.4.

解决方法:把javax.去掉

Could not resolve all dependencies for configuration ‘:compile’.

》 Could not find org.apache.velocity:velocity:1.7-SNAPSHOT.

解决方法:把snapshot去掉

Could not find org.mybatis.generator:mybatis-generator-plugin:1.0-SNAPSHOT.

解决方法:当你build.gradle里找不到这个引用,可以仿照上面commons-codec的方法即可,在build.gradle里增加这个去掉snapshot的引用。
http://ljhzzyx.blog.163.com/blog/static/3838031220134231038329/ (这个方法感觉有源码才行)
http://bbs.csdn.net/topics/380031733

2015.6.30

没有更多推荐了,返回首页