HDU3152 Obstacle Course(BFS)

Problem Description
You are working on the team assisting with programming for the Mars rover. To conserve energy, the rover needs to find optimal paths across the rugged terrain to get from its starting location to its final location. The following is the first approximation for the problem.
N * N square matrices contain the expenses for traversing each individual cell. For each of them, your task is to find the minimum-cost traversal from the top left cell [0][0] to the bottom right cell [N-1][N-1]. Legal moves are up, down, left, and right; that is, either the row index changes by one or the column index changes by one, but not both.
Input
Each problem is specified by a single integer between 2 and 125 giving the number of rows and columns in the N * N square matrix. The file is terminated by the case N = 0.
Following the specification of N you will find N lines, each containing N numbers. These numbers will be given as single digits, zero through nine, separated by single blanks.
Output
Each problem set will be numbered (beginning at one) and will generate a single line giving the problem set and the expense of the minimum-cost path from the top left to the bottom right corner, exactly as shown in the sample output (with only a single space after “Problem” and after the colon).
Sample Input
3
5 5 4
3 9 1
3 2 7
5
3 7 2 0 1
2 8 0 9 1
1 2 1 8 1
9 8 9 2 0
3 6 5 1 5
7
9 0 5 1 1 5 3
4 1 2 1 6 5 3
0 7 6 1 6 8 5
1 1 7 8 3 2 3
9 4 0 7 6 4 1
5 8 3 2 4 8 3
7 4 8 4 8 3 4
0
Sample Output
Problem 1: 20
Problem 2: 19
Problem 3: 36
Source
2008 ACM-ICPC Pacific Northwest Region

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<queue>
#include<set>
#include<iterator>
#include<map>
#include<stack>
using namespace std;
typedef pair<int, int> P;
const int inf = 1e9;
int n;
int land[130][130];
int dx[4] = {0, 0, 1, -1};
int dy[4] = {1, -1, 0, 0};
int exps[130][130];

bool legal(int x, int y){
    return x >= 0 && x < n && y >= 0 && y < n;
}

void bfs(){
    queue<P> que;
    que.push(P(0,0));
    exps[0][0] = land[0][0];
    while(!que.empty()){
        P p = que.front();
        que.pop();
        for(int i = 0; i < 4; i++){
            int nx = p.first + dx[i];
            int ny = p.second + dy[i];
            if(legal(nx, ny)){
                //cout << "nx: " << nx << " ny: " << ny << endl;
                //cout << "expsNxNy: " << exps[nx][ny] << endl;
                //cout << "expsPxPy: " << exps[p.first][p.second] << endl;
                //cout << "landNxNy: " << land[nx][ny] << endl;
                if(exps[nx][ny] > exps[p.first][p.second] + land[nx][ny]){
                    exps[nx][ny] = exps[p.first][p.second] + land[nx][ny];
                    que.push(P(nx, ny));
                }
            }
        }
    }   
}


int main()
{   
    int cs = 1;
    while(scanf("%d", &n)){
        if(n == 0) break;
        for(int i = 0; i < n; i++){
            for(int j = 0; j < n; j++){
                scanf("%d", &land[i][j]);
                exps[i][j] = inf;
            }
        }
        bfs();
        printf("Problem %d: %d\n", cs++, exps[n-1][n-1]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值