高精度减法

【 题目描述 】

输入2个整数m,n(0<m,n<1025),求这两个数的差并输出。

【 输入 】

输入两个整数,每个整数占一行

【 输出 】

输出这两个整数的差


【 样例输入 】
7
2
【 样例输出 】
5

 

#include<iostream>
#include<string>
#include <iostream> 
#include <bits/stdc++.h>
using namespace std;
const int N = 10090;
int a[N], b[N], c[N];
int flag = 0;
int main()
{
    string str1;
    string str2;
    cin >> str1;
    cin >> str2;
    if ((atoi(str1.c_str()) < atoi(str2.c_str()) && str1.size() == str2.size()) || str1.size() < str2.size()){
        swap(str1, str2);
        flag = 1;
    }
    for (int i = 0; i < str1.size(); i ++)
        a[str1.size()-1-i] = str1[i] - '0';
    for (int i = 0; i < str2.size(); i ++)
        b[str2.size()-i-1] = str2[i] - '0';
    int ans = max(str1.size(), str2.size());
    for (int i = 0; i < ans; i ++){
        if (a[i] < b[i]){
            a[i+1] -= 1;
            a[i] += 10;
        }c[i] = a[i] - b[i];
    }
    while (c[ans-1] == 0 && ans > 1)
        ans -= 1;
    if (flag == 1)
        cout << "-";
    for (int i = 0; i < ans; i ++)
        cout << c[ans-1-i];
    return 0;
}
//(*^▽^*)

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值