POJ1328----Radar Installation

转自:http://ren.iteye.com/blog/344093


Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 38045 Accepted: 8452

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

变量pre为前一个圆所能表示的最右边的坐标,然后用贪心的思想从左到右遍历并不断更新就好了


#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;

int n, d;
typedef struct {
	double left, right;
}Point;
Point islands[1000];

bool compare(Point a, Point b)
{
	return (a.left-b.left) < 10e-7;
}

int greedy()
{	//贪心法计算最小需要的radar数
	int ans = 1;
	double pre = islands[0].right;	//前一radar的位置
	for(int i = 1; i < n; i++) {
		if(islands[i].left-pre > 10e-7) {
			ans++;
			pre = islands[i].right;
		} else {
			if(islands[i].right-pre < 10e-7)
				pre = islands[i].right;
		}
	}
	return ans;
}

int main() 
{
	int cas = 0, x, y;
	while(scanf("%d%d", &n, &d) != EOF) {
		if(!n && !d)
			break;
		bool impossible = false;
		for(int i = 0; i < n; i++) {
			scanf("%d%d", &x, &y);
			if(!impossible && (y <= d)) {
				double tmp = sqrt(double(d*d-y*y));
				islands[i].left = x-tmp;
				islands[i].right = x+tmp;
			}
			else
				impossible = true;
		}
		if(impossible) {
			printf("Case %d: -1\n", ++cas);
			continue;
		}
		sort(islands, islands+n, compare);//将island按左端点left由小到大排序

		printf("Case %d: %d\n", ++cas,greedy());
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值