统计某类完全平方数

该程序实现了一个Java函数,用于检查在给定范围内(n1到n2)的整数是否为完全平方数并且至少有两个数字相同。函数isSquare判断平方性,issame判断数字是否有重复。程序遍历范围并统计符合条件的数。
摘要由CSDN通过智能技术生成

本题要求实现一个函数,判断任一给定整数N是否满足条件:它是完全平方数,又至少有两位数字相同,如144、676等。

函数接口定义:
int IsTheNumber ( const int N );
其中N是用户传入的参数。如果N满足条件,则该函数必须返回1,否则返回0。

裁判测试程序样例:
#include <stdio.h>
#include <math.h>

int IsTheNumber ( const int N );

int main()
{
int n1, n2, i, cnt;

scanf("%d %d", &n1, &n2);
cnt = 0;
for ( i=n1; i<=n2; i++ ) {
    if ( IsTheNumber(i) )
        cnt++;
}
printf("cnt = %d\n", cnt);

return 0;

}

/* 你的代码将被嵌在这里 */
输入样例:
105 500
输出样例:
cnt = 6
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB

import java.util.Scanner;

public class text2 {
	public static void main(String[] args) {
		int n1, m1, cnt = 0;
		Scanner sc = new Scanner(System.in);
		n1 = sc.nextInt();
		m1 = sc.nextInt();
		for (int i = n1; i <= m1; i++) {
			if(isSquare(i) && issame(i)) {
				cnt++;
				System.out.println(i);
			}
			
		}
		System.out.println(cnt);
	}
	


	public static boolean isSquare(int i) {
		if(i == (int)Math.sqrt(i)*(int)Math.sqrt(i)) 
			return true;
		else
			return false;
	}
	public static boolean issame(int i) {
		int ge,shi,bai;
		bai = i/100;
		ge = i%10;
		shi = i/10%10;
		if(ge==shi || ge==bai || shi==bai)
			return true;
		else
			return false;}
	}

			```

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值