本题要求实现一个函数,判断任一给定整数N是否满足条件:它是完全平方数,又至少有两位数字相同,如144、676等。
函数接口定义:
int IsTheNumber ( const int N );
其中N是用户传入的参数。如果N满足条件,则该函数必须返回1,否则返回0。
裁判测试程序样例:
#include <stdio.h>
#include <math.h>
int IsTheNumber ( const int N );
int main()
{
int n1, n2, i, cnt;
scanf("%d %d", &n1, &n2);
cnt = 0;
for ( i=n1; i<=n2; i++ ) {
if ( IsTheNumber(i) )
cnt++;
}
printf("cnt = %d\n", cnt);
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
105 500
输出样例:
cnt = 6
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB
import java.util.Scanner;
public class text2 {
public static void main(String[] args) {
int n1, m1, cnt = 0;
Scanner sc = new Scanner(System.in);
n1 = sc.nextInt();
m1 = sc.nextInt();
for (int i = n1; i <= m1; i++) {
if(isSquare(i) && issame(i)) {
cnt++;
System.out.println(i);
}
}
System.out.println(cnt);
}
public static boolean isSquare(int i) {
if(i == (int)Math.sqrt(i)*(int)Math.sqrt(i))
return true;
else
return false;
}
public static boolean issame(int i) {
int ge,shi,bai;
bai = i/100;
ge = i%10;
shi = i/10%10;
if(ge==shi || ge==bai || shi==bai)
return true;
else
return false;}
}
```