我为汕头大学OJ出的题目-Reverse Points

Reverse Points

Time limit: 1 Seconds   Memory limit: 32768 Kb  
Total Submit: 116    Accepted Submit: 24   

Description

We know Doctor Sun is very interested in geometry problems. Now he is fascinated by such a problem: On Cartesian plane, if two points (x1,y1) and (x2,y2) have the property that x1<x2 and y1>y2, we call them a pair of “Reverse Points”. Now given N points on the plane, calculate how many pairs of “Reverse Points” are among them. In his opinion, it is an interesting problem but not a hard problem. So he wants to ask you to write a program and solve it. Can you?

In this problem, you can assume that no two points have the same x- coordinate or y-coordinate.

Input

The input consists of a series of data sets. Each data set begins with a line containing an integer N (N<=50000), which indicates the number of points in the data set. N lines describing the coordinates of the points follow it. Each of the N lines has two integers X and Y, describing the x- and y-coordinates of a point, respectively. You must process to the end of file.

Output

For each data set, you must output the number of pairs of “Reverse Points”. No other characters including leading and trailing spaces should be printed.

Sample Input

2
1 2
2 1

Sample Output

1

Author: Hong Sun, ACM/ICPC team member of SCUT
Conner: Jianquan Liu, Coach Assistant of STU

Algorithm:

直接计算的复杂度是O(N^2),不可取。应先对点按x大小排序,然后分治,对点按y大小归并排序,同时统计。

下面是我的代码:

//by Sun Hong;  May 4th,2005
//Algorithm--Divide and Conquer,complexity--O(N*logN)

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

const int maxn=50000;
typedef struct
{
 int x,y;
}Tpoint;
Tpoint p[maxn],tp[maxn];
int N,ans;

int cmp_x(const void *t1,const void *t2)
{
 Tpoint *a,*b;
 a=(Tpoint*)t1; b=(Tpoint*)t2;
 return a->x-b->x;
}
void swap(Tpoint &a,Tpoint &b)
{
 Tpoint temp;
 temp=a; a=b; b=temp;
}
void MergeSort(int left,int right)
{
 int mid,i,j,k;
 mid=(left+right)/2;
 if (right-left<=1)
 {
  if (p[left].y>p[right].y)
  {
   ans++; swap(p[left],p[right]);
  }
  return;
 }
 MergeSort(left,mid); MergeSort(mid+1,right);
 i=mid; j=right; k=right-left;
 while (i>=left && j>mid)
 {
  if (p[i].y>p[j].y){
   ans+=j-mid; tp[k--]=p[i--];
  }else
   tp[k--]=p[j--];
 }
 while (i>=left) tp[k--]=p[i--];
 while (j>mid) tp[k--]=p[j--];
 memcpy(p+left,tp,(right-left+1)*sizeof(Tpoint));
}
int main()
{
 int i;
 //freopen("points.in","r",stdin);
 //freopen("points.out","w",stdout);
 while (1==scanf("%d",&N))
 {
  for (i=0;i<N;i++) scanf("%d%d",&p[i].x,&p[i].y);
  qsort(p,N,sizeof(Tpoint),cmp_x);
  ans=0;
  MergeSort(0,N-1);
  printf("%d/n",ans);
 }
 return 0;
}

基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip 个人大四的毕业设计、课程设计、作业、经导师指导并认可通过的高分设计项目,评审平均分达96.5分。主要针对计算机相关专业的正在做毕设的学生和需要项目实战练习的学习者,也可作为课程设计、期末大作业。 [资源说明] 不懂运行,下载完可以私聊问,可远程教学 该资源内项目源码是个人的毕设或者课设、作业,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96.5分,放心下载使用! 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),供学习参考。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值